WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15235 closed defect (bug) (invalid)

add_rewrite_rules and default permalink structure

Reported by: arena Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

hooks 'generate_rewrite_rules' & 'rewrite_rules_array' are never activated if permalink structure is default
(non_wp_rules !!)

Change History (6)

comment:1 nacin3 years ago

What's the problem here? If there is no rewriting, then no htaccess file, no rules to filter, anything of the sort.

Please be more specific in your "bug" reports. Nearly every one someone has to ask for more information on why such and such is a bug. Thanks.

comment:2 nacin3 years ago

  • Keywords reporter-feedback close added

comment:3 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

comment:4 arena3 years ago

  • Keywords close removed
  • Resolution invalid deleted
  • Status changed from closed to reopened

wordpress wp_rewrite api gives the ability to have non_wp_rules ...

so if there is no wordpress rewrite rules there can be non_wp_rules to wrtie in the .htaccess !!!

comment:5 nacin3 years ago

This is by design. If there are no rewrite rules, then we're not writing anything to an htaccess file. That means we'll ignore any non_wp_rules.

comment:6 nacin3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

No rewrites means no file means we can't add any rules to the file.

Note: See TracTickets for help on using tickets.