WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 8 months ago

Last modified 8 months ago

#15237 closed defect (bug) (invalid)

Settings -> Permalinks blank on PHP 5.3.2

Reported by: EdwardIII Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Permalinks Keywords: reporter-feedback
Focuses: Cc:

Description

I've setup a brand new wordpress with a fresh db for testing this.

To replicate this, install WordPress in an environment with PHP 5.3.2:

# run through the standard installation
# login
# click Settings -> Permalinks
# Observe the bleak, white, cold content area looking back at you

Works fine in this scenario when I revert to PHP Version 4.4.9.

I tried enabling debug mode, then in php.ini setting display_errors = On and ERROR_REPORTING = E_ALL but still couldn't view any output on the page in question.

I'm attaching the phpinfo for the broken setup to this bug.

Attachments (2)

output.txt (9.4 KB) - added by EdwardIII 3 years ago.
info.txt (15.6 KB) - added by duck_ 3 years ago.

Download all attachments as: .zip

Change History (21)

EdwardIII3 years ago

comment:1 EdwardIII3 years ago

Forgot to add, this is for the latest release of WordPress Version 3.0.1 installed from http://wordpress.org/latest.tar.gz

comment:2 nacin3 years ago

OK - we've seen this before (possibly) -- #15044

comment:3 EdwardIII3 years ago

Wow, fast response! If you want any more info about my system let me know. I did a quick search on 'permalinks' in Trac but didn't spot an existing ticket on this issue.

comment:4 nacin3 years ago

I would love to narrow this down -- it looks like it's the ob_get_clean(), or something? I'll have to ask some PHP friends.

Also, more information at #15038. We can probably consolidate these but this is tough to diagnose so I'm unsure.

I'm running 5.3.1, but I'll try to get a test environment going that can reproduce.

comment:5 follow-up: duck_3 years ago

For me Settings > Permalinks is fine on my local 5.3.2 install (both WP trunk and 3.0.1)

comment:6 EdwardIII3 years ago

duck_: is there any chance you could post your phpinfo?

comment:7 in reply to: ↑ 5 ; follow-up: edwardiii3 years ago

Replying to duck_:

For me Settings > Permalinks is fine on my local 5.3.2 install (both WP trunk and 3.0.1)

Probably should've hit 'reply' instead of making a new post.

duck_: Any chance you could post your phpinfo as an attachment?

Thanks

comment:8 in reply to: ↑ 7 ; follow-up: duck_3 years ago

Replying to edwardiii:

Replying to duck_:

For me Settings > Permalinks is fine on my local 5.3.2 install (both WP trunk and 3.0.1)

Probably should've hit 'reply' instead of making a new post.

Sorry was my fault, saw your original request but completely forgot. Uploading now.

duck_3 years ago

comment:9 in reply to: ↑ 8 edwardiii3 years ago

Replying to duck_:

Sorry was my fault, saw your original request but completely forgot. Uploading now.

Thanks! The main differences I can see are that your version uses Suhosin and the ubuntu packaged version of PHP. Maybe one of those vendors has patched something which doesn't cause this problem to occur?

It's possible I'm off the track though - there are a number of other differences too, I've got curl, we have different settings for url_fopen. I guess we need to try ruling some of these out?

comment:10 follow-up: nacin3 years ago

Still haven't a clue on this. Not in #15038 either. Might need to see an affected server and actually dig in.

comment:11 markjaquith3 years ago

Cannot reproduce on PHP 5.3.2.

comment:12 in reply to: ↑ 10 ; follow-up: EdwardIII3 years ago

Replying to nacin:

Still haven't a clue on this. Not in #15038 either. Might need to see an affected server and actually dig in.

I can't give you root but how about a user account where the problem is happening?

comment:13 in reply to: ↑ 12 nacin3 years ago

Replying to EdwardIII:

Replying to nacin:

Still haven't a clue on this. Not in #15038 either. Might need to see an affected server and actually dig in.

I can't give you root but how about a user account where the problem is happening?

That'd be great -- can you email me at my username at wordpress.org? MarkJaquith and I are going to take a look.

comment:14 nacin3 years ago

  • Version set to 3.0

comment:15 kcristiano3 years ago

Not sure if this is will help, but I had this issue with php 5.3.2 on CentOS 5.5 and Apache 2.2. In the end I recompiled php disabling the pdo drivers for mysql. Once that was done, everything worked fine.

I do not know why this happened, but this was the change that worked for me. YMMV.

comment:16 follow-up: ollieread3 years ago

  • Keywords changed from permalinks, blank to permalinks blank

If you're running PHP as CGI you won't have access to the apache PHP API so apache_get_modules() will fail. On top of this, if you're using Apache 2.2+ mod_rewrite is statically compiled so it won't show up in phpinfo(8) either.

I had this issue and after recompiling PHP and removing the 'Compiled as CGI option' I was able to view the permalinks page again.

comment:17 in reply to: ↑ 16 edwardiii3 years ago

Replying to ollieread:

If you're running PHP as CGI you won't have access to the apache PHP API so apache_get_modules() will fail.

This seems to be a fairly common configuration (e.g. cPanel defaults). Should there be a WordPress configuration option to force-enable permalinks in cases where apache_get_modules seems to be returning erroneous results?

comment:18 c3mdigital8 months ago

  • Keywords close added; permalinks blank removed
  • Resolution set to invalid
  • Status changed from new to closed

No chatter in 2 years. This seems to be a non issue If anyone can reproduce this on please reopen.

comment:19 SergeyBiryukov8 months ago

  • Keywords reporter-feedback added; close removed
  • Milestone Awaiting Review deleted
  • Severity changed from major to normal
Note: See TracTickets for help on using tickets.