WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 21 months ago

#15244 closed defect (bug) (duplicate)

Cut cropped filename

Reported by: charlie_hun Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Upload Keywords: reporter-feedback
Focuses: Cc:

Description

If I upload file, when nam start with Í

Attachments (1)

bug.sql (1.6 KB) - added by charlie_hun 3 years ago.
The database dump

Download all attachments as: .zip

Change History (5)

comment:1 charlie_hun3 years ago

  • Cc janos@… added
  • Component changed from General to Upload
  • Keywords file upload added
  • Version set to 3.0.1

If I upload file, when nam start with Í (http://en.wikipedia.org/wiki/%C3%8D), like Írás.png, missing the Í characte the wordpress created cropped file name.

Eq.:

I upload file Írás.png. And I saw this in the filesystem:

-rw-rw-rw- 1 lighttpd lighttpd 160K Oct 28 23:05 Írás.jpg
-rw-rw-rw- 1 lighttpd lighttpd 34K Oct 28 23:05 rás-610x265.jpg
-rw-rw-rw- 1 lighttpd lighttpd 56K Oct 28 23:05 rás-610x457.jpg
-rw-rw-rw- 1 lighttpd lighttpd 44K Oct 28 23:05 rás-940x198.jpg

In the database:

wp_post table:

(130, 2, '2010-10-28 23:05:10', '2010-10-28 21:05:10', '', 'Írás', '', 'inherit', 'open', 'open', '', 'iras', '', '', '2010-10-28 23:05:10', '2010-10-28 21:05:10', '', 126, 'http://teszt.blogolj.net/files/2010/10/Írás.jpg', 0, 'attachment', 'image/jpeg', 0);

wp_postmeta

(109, 130, '_wp_attached_file', '2010/10/Írás.jpg'),
(110, 130, '_wp_attachment_metadata', 'a:6:{s:5:"width";s:4:"1024";s:6:"height";s:3:"768";s:14:"hwstring_small";s:23:"height=''96'' width=''128''";s:4:"file";s:18:"2010/10/Írás.jpg";s:5:"sizes";a:3:{s:9:"thumbnail";a:3:{s:4:"file";s:16:"rás-610x265.jpg";s:5:"width";s:3:"610";s:6:"height";s:3:"265";}s:6:"medium";a:3:{s:4:"file";s:16:"rás-610x457.jpg";s:5:"width";s:3:"610";s:6:"height";s:3:"457";}s:14:"post-thumbnail";a:3:{s:4:"file";s:16:"rás-940x198.jpg";s:5:"width";s:3:"940";s:6:"height";s:3:"198";}}s:10:"image_meta";a:10:{s:8:"aperture";s:1:"5";s:6:"credit";s:0:"";s:6:"camera";s:15:"FinePix S8000fd";s:7:"caption";s:0:"";s:17:"created_timestamp";s:10:"1247594513";s:9:"copyright";s:0:"";s:12:"focal_length";s:3:"7.1";s:3:"iso";s:2:"64";s:13:"shutter_speed";s:16:"0.00285714285714";s:5:"title";s:0:"";}}');

I probe this bug (109, 130, '_wp_attached_file', '2010/10/Írás.jpg'),
(110, 130, '_wp_attachment_metadata', 'a:6:{s:5:"width";s:4:"1024";s:6:"height";s:3:"768";s:14:"hwstring_small";s:23:"height=''96 width=128";s:4:"file";s:18:"2010/10/Írás.jpg";s:5:"sizes";a:3:{s:9:"thumbnail";a:3:{s:4:"file";s:16:"rás-610x265.jpg";s:5:"width";s:3:"610";s:6:"height";s:3:"265";}s:6:"medium";a:3:{s:4:"file";s:16:"rás-610x457.jpg";s:5:"width";s:3:"610";s:6:"height";s:3:"457";}s:14:"post-thumbnail";a:3:{s:4:"file";s:16:"rás-940x198.jpg";s:5:"width";s:3:"940";s:6:"height";s:3:"198";}}s:10:"image_meta";a:10:{s:8:"aperture";s:1:"5";s:6:"credit";s:0:"";s:6:"camera";s:15:"FinePix S8000fd";s:7:"caption";s:0:"";s:17:"created_timestamp";s:10:"1247594513";s:9:"copyright";s:0:"";s:12:"focal_length";s:3:"7.1";s:3:"iso";s:2:"64";s:13:"shutter_speed";s:16:"0.00285714285714";s:5:"title";s:0:"";}}');

I found this bug in WordPress, when use Apache+mod_php, Apache+FastCGI+PHP, Lighttpd+FastCGI+PHP, with php version 5.2.14 and 5.3.3

Version 0, edited 3 years ago by charlie_hun (next)

charlie_hun3 years ago

The database dump

comment:2 follow-up: mdawaffe3 years ago

  • Keywords reporter-feedback added
  • Milestone changed from Awaiting Review to Future Release

What operating system are you uploading from, and what operating system is your server using?

I cannot reproduce uploading from OS X to OS X under PHP 5.3.4 with a file named Írás.jpg:

chr( 195 ) . chr( 141 ) . chr( 114 ) . chr( 195 ) . chr( 161 ) . chr( 115 ) . '.jpg'

comment:3 in reply to: ↑ 2 charlie_hun3 years ago

Hi,

I found this bug with Linux (Kubuntu) and Windows 7 client with and without flash upload.

I use Linux in my server, but I probe this bug with some (free and paid) hosting (like: dotroll.com, godaddy)

Replying to mdawaffe:

What operating system are you uploading from, and what operating system is your server using?

I cannot reproduce uploading from OS X to OS X under PHP 5.3.4 with a file named Írás.jpg:

chr( 195 ) . chr( 141 ) . chr( 114 ) . chr( 195 ) . chr( 161 ) . chr( 115 ) . '.jpg'

comment:4 SergeyBiryukov21 months ago

  • Keywords file upload removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I could not reproduce the missing character in thumbnail names (as shown in comment:1) in current trunk on Linux with PHP 5.2.17 (on Windows it's more complicated, see ticket:15955:11).

Going to close as a duplicate of #21217. Feel free to reopen if there's still a problem not covered there.

Note: See TracTickets for help on using tickets.