Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#15257 closed defect (bug) (fixed)

Bulk edit posts is broken on trunk

Reported by: nacin Owned by: scribu
Milestone: 3.1 Priority: normal
Severity: major Version:
Component: Quick/Bulk Edit Keywords:
Focuses: Cc:


Change History (7)

#1 @nacin
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [16097]) Fix nested HTML in submit_button(). fixes #15257, see #15064.

#2 @sbressler
5 years ago

Oops :-/ Thanks for fixing

I certainly didn't realize that my patch was going to go in verbatim - definitely thought there might be more review. Makes contributor's work all the more important I guess.

#3 @scribu
5 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

It seems to be broken again, but this time I don't think it's caused by submit_button().

#4 @scribu
5 years ago

Steps to reproduce:

  1. Go to WP-Admin -> Edit -> Posts
  2. Check one or more posts
  3. Select [Bulk Actions] -> Edit
  4. Modify something and click Update

You will get a message saying "X posts updated", but they stay the same.

#5 @sbressler
5 years ago

I'll try to verify later that this wasn't broken with submit_button (could be that the id/name isn't as it was before.

That's not to say someone else shouldn't investigate the broader issue.

#6 @scribu
5 years ago

  • Owner set to scribu
  • Severity changed from normal to major
  • Status changed from reopened to accepted

I'll try to come up with a patch.

#7 @scribu
5 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

Nevermind, it misteriously works now.

Note: See TracTickets for help on using tickets.