WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15272 closed defect (bug) (fixed)

wp importer trunk regression: no longer can create users

Reported by: lloydbudd Owned by: duck_
Milestone: WordPress.org Priority: normal
Severity: normal Version: 3.1
Component: Import Keywords:
Focuses: Cc:

Description (last modified by lloydbudd)

wordpress-importer trunk r306039 no longer can create users

When I import an WXR file from WordPress.com wxr_version 1.0, I'm not prompted to create "Create user or map to existing" like I am in the current version, v0.2.

What's the thinking behind removing this feature? It's necessary when migrating multi-author sites to a new host, and for development and stating.

Additional Details

Relates to #15197 "WXR export/import umbrella ticket"

Change History (9)

comment:1 lloydbudd3 years ago

  • Description modified (diff)

comment:2 follow-up: duck_3 years ago

The problem with importing authors from WXR 1.0 was that the file holds the author names in their display form. This lead to problems when sanitizing that display name to create the new imported author (#10319). It can also cause unexpected changes to the new user's login name (e.g. old site the login was "john" but now it's "John Doe", this cannot be changed from WP admin).

I'll look into better ways of offering the new login (I know the old importer had an input box, but not totally obvious this would be the login since it's prefilled with the display name). I can see that it would be a hassle to set up all the old authors in a new site for mapping for a large number of authors (though this would probably be the most reliable way).

comment:3 lloydbudd3 years ago

I wonder if #10319 isn't being fixed at the wrong layer then, because I've encountered that issue more frequently with Movable Type imports, and it sounds like the way it was fixed won't help with other importers.

If the import appears to be from an old version, can you leave the old behaviour and phase it out at a later release? Fixing the edge case #10319 is going to cause more headaches in the next 6 months than that bug #10319 does. The imports I do often have > 25 authors, and in a pinch to investigate an issue I'll be loading the same import numerous times on clean installs.

comment:4 in reply to: ↑ 2 lloydbudd3 years ago

  • Priority changed from normal to high
  • Severity changed from normal to major

Replying to duck_:
Oh, my assumption based on that reply was that this behaviour only happens for old v1.0 imports. It seems to occur with an export from WordPress Trunk r16120 (3.1-alpha), WXR v1.1.

Is there a sequence where it will create the users on WordPress import? If not, I consider this a more serious regression.

comment:5 lloydbudd3 years ago

  • Priority changed from high to normal
  • Severity changed from major to normal

And I see that I spoke too soon. It does create the users. The disconnect relates to Ticket #15275, and which based on the current behaviour seems like more of a bug than a enhancement now.

"Import author Display Name or map to existing user [menu]" gives no indication about what user it is going to try to create, nor any feedback on what users it did create or what implicit mapping it went with (#15274)

This is particularly confusing if that display name is the Display Name of someone else, or the Username seems to have nothing to do with the other username.

It's not an uncommon scenario for me to be merging sites for customers, and the current behaviour would cause me 1st rate headaches.

comment:6 follow-up: duck_3 years ago

Yep, sorry I wasn't clear enough before the feature's not gone for WXR 1.1 files, it's just you can currently only map users for WXR 1.0. This was the major backwards incompatibility noted in #15197.

Maybe bringing back the input box to allow changing of the login name, like:

Import author John Doe (john) as [John Doe]
or map to existing user [-Select-]

(P.S. thanks for all the feedback. I really needed it from someone who uses import/export frequently!)

comment:7 in reply to: ↑ 6 lloydbudd3 years ago

Replying to duck_:

Maybe bringing back the input box to allow changing of the login name, like:

Import author John Doe (john) as [John Doe]
or map to existing user [-Select-]

Sounds pretty good.

(P.S. thanks for all the feedback. I really needed it from someone who uses import/export frequently!)

You are doing fantastic work!

comment:8 duck_3 years ago

  • Keywords needs-patch removed

http://plugins.trac.wordpress.org/changeset/309430

Allows creation of new users with whatever login name you supply. Will still refuse to import users with no login safe characters in the display name and I guess there's the possibility of incorrect mapping since sanitize_user is many-to-one. This is only a problem for WXR 1.0 since from 3.1 exports will use a user's login name for post association.

comment:9 duck_3 years ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.