Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#15288 closed defect (bug) (invalid)

Plugin directory versioning isn't working correctly for Advanced Custom Field Widget

Reported by: AthenaOfDelphi Owned by:
Milestone: Priority: normal
Severity: critical Version:
Component: WordPress.org site Keywords: plugin directory version
Focuses: Cc:



One of the two plugins I maintain (Advanced Custom Field Widget - http://wordpress.org/extend/plugins/advanced-custom-field-widget/) is having some problems in the directory.

I a new version a week or two ago, but the directory believes the latest version is an empty string. Consequently, blogs that use the plugin aren't recognising the latest version.

I thought it may be linked to http://core.trac.wordpress.org/ticket/15138 initially, so I commented on that ticket.

I've checked all my files and I can see no reason why the version information in the file should suddenly stop working. I tried a different version number just in case it was some sort of sorting error, but nothing has helped. Up to now, every new version has worked without a hitch.

Today I received a request for support from a user relating to this issue and so, I'm elevating it by raising a ticket.

The original update went like this:-

Uploaded 0.9 in trunk
Created tags\0.9 locally and checked it in

After about 15-20mins, the directory was showing the Download button with just 'Download', not 'Download <version>'. The current version was showing as a blank string, but version 0.9 was listed in the versions.

I have since tried to fix this by creating a version 0.90 (which I messed up by failing to check in the trunk before the tagged version) and then 0.91.

Nothing has worked and the system is still showing an empty string for the current version and blogs don't recognise that these is a new version available.

And on a slightly different note, can I delete the erroneous version (0.9, 0.90, 0.91)?

If you need any further information, please don't hesitate to drop me a mail.

Kind Regards

(aka. AthenaOfDelphi)

Change History (3)

#1 @AthenaOfDelphi
5 years ago

  • Component changed from Plugins to WordPress.org
  • Severity changed from major to critical

#2 @AthenaOfDelphi
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

The issue appears to have been caused by retaining a change history in the plugins PHP file. Removing it (at version 0.97) appears to have resolved it.

Marking the issue as resolved/invalid.

#3 @ocean90
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.