WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#15294 closed defect (bug) (duplicate)

Import WXR 1.0 cannot create users

Reported by: Dene Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Import Keywords:
Focuses: Cc:

Description

Related to Changeset 15961

The attached wordpress.xml imports without errors using importer version 2 but generates many duplicates categories. It also imports users but not their profile information.

Using WordPress importer v3, the duplicate category issues are resolved (yeah) but users are not imported at all. All posts are assigned to 'admin'. The v3 import also produces attached errors.

Please let me know if I did something wrong or you need more details.

Thanks.

Attachments (2)

wordpress importer errors.txt (3.8 KB) - added by Dene 4 years ago.
wordpress import file
wordpress.2010-01-01.2010-03-01.zip (159.6 KB) - added by Dene 4 years ago.
wordpress import file

Download all attachments as: .zip

Change History (4)

@Dene4 years ago

wordpress import file

@Dene4 years ago

wordpress import file

comment:1 in reply to: ↑ description @duck_4 years ago

  • Keywords wordpress importer removed
  • Milestone Awaiting Review deleted
  • Summary changed from Errors with WordPress Importer Version 0.3-beta1 / WordPress 3.1-alpha to Import WXR 1.0 cannot create users
  • Version 3.1 deleted

Replying to Dene:

Using WordPress importer v3, the duplicate category issues are resolved (yeah) but users are not imported at all. All posts are assigned to 'admin'. The v3 import also produces attached errors.

See #15272 about importing users when using WXR 1.0 files (note you can still map to an existing user now [0.3-beta1]). Coming up with a fix now.

The XML errors are about an ending CDATA tag within one of your post's content, see #15203

The other errors are to do with missing attachments (cannot reproduce with the attached file since there are no attachment details within) and the impossibility of importing nav menu items properly from WXR 1.0 (see #15197, may look again at blocking these errors from appearing and showing a single one instead).

I am going to change the summary to reflect the main issue you have (as far as I can tell) which is not creating new users for WXR 1.0. Closing as duplicate.

Though thanks for the report :)

comment:2 @duck_4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Actually close as dupe

Note: See TracTickets for help on using tickets.