WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#1532 closed defect (bug) (fixed)

wp_notify_postauthor() sends pingback/trackback e-mails from bad address

Reported by: markjaquith Owned by: markjaquith
Milestone: Priority: normal
Severity: normal Version: 1.5.1.2
Component: Administration Keywords: bg|has-patch bg|commit
Focuses: Cc:

Description

wp_notify_postauthor() sends pingback and trackback notification e-mails from wordpress@$_SERVERSERVER_NAME?

The problem is that on some hosts, $_SERVERSERVER_NAME? is in the form of www.domain.com instead of just domain.com

These wordpress@… e-mails are getting deleted somewhere along the line as obviously bogus.

We need to check for leading www. and strip it out.

Attachments (2)

bug1532.diff (822 bytes) - added by graeme 10 years ago.
email_from_wordpress_at_domain.diff (1.6 KB) - added by markjaquith 10 years ago.
Email sent from wordpress@domain (with "www." stripped)

Download all attachments as: .zip

Change History (9)

@graeme10 years ago

comment:1 @graeme10 years ago

  • Owner changed from anonymous to graeme

comment:2 @graeme10 years ago

  • Keywords bg|2nd-opinion added; bg|needs-patch removed

comment:3 @graeme10 years ago

  • Keywords bg|has-patch added

comment:4 @matt10 years ago

  • Keywords bg|has-patch removed

This doesn't really fix the core problem though, what should we send system generated mails out as from:? In other parts of the code we use admin email.

@markjaquith10 years ago

Email sent from wordpress@domain (with "www." stripped)

comment:5 @markjaquith10 years ago

  • Keywords bg|has-patch bg|commit added; bg|2nd-opinion removed
  • Owner changed from graeme to markjaquith
  • Status changed from new to assigned

Final decision was that wordpress@domain is best, because admin email might be from off-domain and might be more likely to get flagged as spam at its destination.

comment:6 @matt10 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [3214]) Better email from, fixes #1532

comment:7 @anonymous9 years ago

  • Milestone 2.0 deleted

Milestone 2.0 deleted

Note: See TracTickets for help on using tickets.