WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15331 closed defect (bug) (duplicate)

Certain special characters can break pretty permalinks

Reported by: andrewspittle Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Permalinks Keywords:
Focuses: Cc:

Description

When adding the è character to a post title the permalink is no longer pretty.

To reproduce, create a title such as "Jornades a l’ENSSIB sobre els projectes de bibliografia del llibre antic a l’època de la digitalització"

The permalink generated will end in:

/jornades-a-l%E2%80%99enssib-sobre-els-projectes-de-bibliografia-del-llibre-antic-a-l%E2%80%99epoca-de-la-digitalitzacio/

The permalink will still work when clicked on but ideally shouldn't contain the extra character junk.

Change History (1)

comment:1 scribu3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

The problem isn't the è, but the character.

Marking as dup of #3843

Note: See TracTickets for help on using tickets.