WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15354 closed defect (bug) (fixed)

Remove extra padding after bulk actions

Reported by: nacin Owned by:
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: Administration Keywords:
Focuses: Cc:

Description

In 3.0, bulk actions and page numbers were flush against the top of the list tables.

On some screens in 3.1, this is no longer the case. I've noticed it on link-manager and edit-tags in particular.

Example: http://cl.ly/ccfa7c03d2c8961dcb5c

Change History (6)

comment:1 edward mindreantre3 years ago

Bulk actions are almost flush for me (5px). The padding seems way larger for you, though.

Care to inform us of which os/browser you're using?

comment:2 edward mindreantre3 years ago

I use Linux FF 3.6.12, btw.

comment:3 nacin3 years ago

Chrome stable on Mac. Can't reproduce in Firefox. Can in Safari, so it's a Webkit rendering issue we're not accounting for.

comment:4 follow-up: markjaquith3 years ago

The <br class="clear" /> appears to be causing this. Removing it makes the issue go away. Do we need that <br /> ? Our .widefat tables have clear:both already. Seems to work without it.

comment:5 in reply to: ↑ 4 nacin3 years ago

Replying to markjaquith:

The <br class="clear" /> appears to be causing this. Removing it makes the issue go away. Do we need that <br /> ? Our .widefat tables have clear:both already. Seems to work without it.

In 3.0, these were <div class="clear"></div> instead of <br class="clear"/>. That fixes the problem. But it certainly looks like the clear between tablenav and widefat is unnecessary.

comment:6 nacin3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [16442]) Kill unnecessary br.clear after div.tablenav. fixes #15354.

Note: See TracTickets for help on using tickets.