WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15356 closed defect (bug) (fixed)

edit-tags AJAX add is broken

Reported by: nacin Owned by:
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

See title.

Attachments (2)

15356.patch (378 bytes) - added by ocean90 3 years ago.
15356_button_conflict.patch (647 bytes) - added by batmoo 3 years ago.

Download all attachments as: .zip

Change History (6)

ocean903 years ago

comment:1 ocean903 years ago

  • Keywords has-patch added

Use .live('click', ... instead of .click().

comment:2 batmoo3 years ago

Root cause is that there are two buttons with the id of "submit". Patch renames the search button id & name to "search-items" and retains the "submit" id for the "Add Term" button.

comment:3 nacin3 years ago

I didn't think it was bind versus live. Thanks for tracking this down Mo!

comment:4 scribu3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [16655]) Fix edit-tags button conflict. Props batmoo. Fixes #15356

Note: See TracTickets for help on using tickets.