WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#15357 closed defect (bug) (fixed)

Super Admins can no longer add new users to their networks unless they also "Allow site administrators to add new users to their site via the 'Users->Add New' page"

Reported by: caesarsgrunt Owned by:
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: Network Admin Keywords:
Focuses: multisite Cc:

Description

Previously (up to 3.0.1) it was possible for Super Admins to add new users to their networks.

Now, Super Admins can no longer add new users to their networks unless they enable the setting to Allow site administrators to add new users to their site via the "Users->Add New" page.

However, Super Admins may want to add new users without also allowing their users to add new users.

I don't know why this feature has been removed or whether it was intentional, but unless there is a good reason to remove it, it should be restored.

Attachments (1)

15357.diff (487 bytes) - added by ryan 11 years ago.
Always allow create_users to super admins

Download all attachments as: .zip

Change History (13)

#1 @caesarsgrunt
11 years ago

  • Component changed from Administration to Network Admin

#2 @markmcwilliams
11 years ago

I'd say this is almost a duplicate of your other ticket (#15358) as their both related!

#3 @caesarsgrunt
11 years ago

Both related, yes, but separate issues - I think! :-)

#4 follow-up: @ryan
11 years ago

My suggestion: Super admins should always have create_users. A new cap, add_users, can control whether existing users can be added to a blog. Site admins and super admins would have this cap. If the add_new_users flag is true, then site admins can also have create_users. user-new.php should check add_users and create_users and present accordingly.

#5 in reply to: ↑ 4 @westi
11 years ago

Replying to ryan:

My suggestion: Super admins should always have create_users. A new cap, add_users, can control whether existing users can be added to a blog. Site admins and super admins would have this cap. If the add_new_users flag is true, then site admins can also have create_users. user-new.php should check add_users and create_users and present accordingly.

Perfect

@ryan
11 years ago

Always allow create_users to super admins

#6 @ryan
11 years ago

(In [16264]) Always allow super admins to have create_users. see #15357

#7 @nacin
11 years ago

  • Milestone changed from Awaiting Review to 3.1

Per IRC discussion, we should leverage promote_user(s) otherwise for all role changes (including adding user to blog, as they're going from no role) -- and that includes on user-edit.php.

#8 @ryan
11 years ago

(In [16294]) user-new.php revamp. Separate caps for adding users vs. creating users. Allow supes to add via email or username. Split adding existing users and creating new users into separate forms. see #15357

#9 @ryan
11 years ago

(In [16295]) Better styling for add user form fields. see #15357

#10 @ryan
11 years ago

(In [16296]) Marksup fixes. see #15357

#11 @ryan
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

#12 @ryan
11 years ago

(In [16551]) Make sure create_users is strippped from blog admins for multisite setups where add_new_users is not enabled. see #15357

Note: See TracTickets for help on using tickets.