WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#15391 closed defect (bug) (invalid)

Autosave doesn't take custom Post Meta Data

Reported by: SteveAtty Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: General Keywords:
Focuses: Cc:

Description

When Autosave fires the $_POST array only contains the basic information for the Post. Any custom post meta data is not transferred which means that unless a user then does a hard save before quitting the Edit Post screen any changes to custom meta are lost.

Change History (1)

comment:1 nacin3 years ago

  • Keywords autosave custom meta removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Autosaves aren't designed to be real saves -- it's a stopgap to ensure you don't lose data accidentally. This data means content, title, and such. Everything else indeed isn't saved by design. You need to do a hard save.

Additionally, most custom field actions get saved via AJAX from the custom fields box.

Note: See TracTickets for help on using tickets.