WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15436 closed defect (bug) (invalid)

RSS Widget Title not linking to feed source

Reported by: alettieri Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Widgets Keywords: rss, widget, rss widget
Focuses: Cc:

Description

There is a bug in the WP_Widget_RSS class in the (default-widgets.php) file.

Line: 740

$title = "<a class='rsswidget' href='$url' title='" . esc_attr__( 'Syndicate this content' ) ."'><img style='border:0' width='14' height='14' src='$icon' alt='RSS' /></a> <a class='rsswidget' href='$link' title='$desc'>$title</a>";

Fix:

$title = "<a class='rsswidget' href='$url' title='" . esc_attr__( 'Syndicate this content' ) ."'><img style='border:0' width='14' height='14' src='$icon' alt='RSS' /></a> <a class='rsswidget' href='$url' title='$desc'>$title</a>";

Change History (3)

comment:1 scribu3 years ago

  • Milestone changed from Awaiting Review to 3.1

comment:2 nacin3 years ago

  • Milestone 3.1 deleted
  • Resolution set to invalid
  • Status changed from new to closed

That's not a bug. It links to the site being syndicated, versus the feed (which is where the icon goes).

comment:3 scribu3 years ago

Ah, you beat me to it.

Note: See TracTickets for help on using tickets.