WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#15444 closed defect (bug) (duplicate)

Single quotes after phrase elements are backwards (wptexturize)

Reported by: alexkingorg Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: General Keywords:
Focuses: Cc:

Description

Perhaps related to #15241 it appears that situations like this are not handled properly:

<a href="#">Jim</a>'s red bike.

The quotes are turned backwards. Perhaps phrase elements such as A, SPAN, EM, STRONG, B, need special handling?

Please merge with #15241 if this is a duplicate or fixed by the same solution.

Attachments (1)

test_includes_formatting.php.diff (681 bytes) - added by norbertm 4 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 @nacin4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate. Going to up the priority on the other ticket. This would be a good unit test case.

comment:2 @nacin4 years ago

  • Milestone set to Awaiting Review
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Sorry, I didn't realize this wasn't a 3.1-specific report. Reproduced in 3.0.

comment:3 @nacin4 years ago

  • Version set to 3.0

comment:4 @norbertm4 years ago

  • Cc norbert@… added

comment:5 @norbertm4 years ago

Fix and test cases now included in #4539 for 3.1+.

comment:6 @nacin4 years ago

Related: #10606

comment:7 @nacin4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.