WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 19 months ago

#15481 closed enhancement (wontfix)

Make ajax searches search automatically

Reported by: edward mindreantre Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.1
Component: Administration Keywords: has-patch ux-feedback needs-refresh
Focuses: Cc:

Description

Usually one has to press enter before the post/page search activates.

I'm too lazy to press enter, so I prefer the results come up as I type.

Here's the patch for that.

scribu says we should all have a long discussion as to whether to have this or not.

I'd rather wait 5 seconds than press enter, though... Because I'm effective like that.

Attachments (1)

list-table.dev.js-x7815.diff (1.9 KB) - added by edward mindreantre 4 years ago.
1 second keypress, now with fixed race condition

Download all attachments as: .zip

Change History (9)

comment:1 scribu4 years ago

  • Keywords has-patch ux-feedback added

comment:2 scribu4 years ago

Related: #14579

comment:3 voyagerfan57614 years ago

  • Cc WordPress@… added

comment:4 edward mindreantre4 years ago

  • Cc edward@… added

edward mindreantre4 years ago

1 second keypress, now with fixed race condition

comment:5 nacin4 years ago

  • Milestone changed from Awaiting Review to Future Release

comment:6 chexee3 years ago

  • Keywords needs-refresh added

Not sure how long a discussion did or did not occur, but I'd like to see live search implemented.

The patch appears to be out of date and is referencing a file that no longer exists or was moved.

Related: #19452

comment:7 csixty419 months ago

  • Cc csixty4 added

Since this ticket is still sitting around unclosed, I thought I'd fill in a little history for chexee and anyone else who might come across it.

Scribu's 2010 GSOC project was to "Ajaxify" the admin interface, and he had much success. So much, in fact, that his patches were included in the first alphas & release candidates of WordPress 3.1. As this ticket relates to version 3.1, I can only assume the patches apply to those versions as well. However, these changes introduced bugs and usability issues so they were removed from WordPress 3.1R3.

From my own research into this, I will add that this change isn't as simple as bolting some Javascript on top of the WordPress admin. I mean, you probably could, but it would be sub-optimal from a performance & UX standpoint. Doing it right would require refactoring legacy PHP code, especially wp-admin/edit.php, to render admin page as partials which can also be invoked from an wp_ajax_* hook. That refactoring should come first, and tested throughly for regression issues. Only then should AJAX functionality be added, maybe even as part of a different point release entirely.

See also #14579

comment:8 nacin19 months ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Going to close as wontfix since pulled out ajax list tables, and may implement them in an entirely different way if/when we do.

Note: See TracTickets for help on using tickets.