WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15482 closed defect (bug) (duplicate)

AJAX searches should show the loading spinner

Reported by: batmoo Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

If an AJAX search takes too long, it looks like something's broken. Add a loading spinner beside the search box while loading so users don't freak out.

Attachments (2)

15482.diff (1.6 KB) - added by batmoo 3 years ago.
15482_fix_loading_overlay.diff (468 bytes) - added by batmoo 3 years ago.
Fixes loading overlay (was missing a closing quote)

Download all attachments as: .zip

Change History (8)

comment:1 nacin3 years ago

Scribu batmoo et al, I would hold off on work on this until Jane posts the complete results of the user testing in the next few days. This will likely be closed as a duplicate of her ticket.

batmoo3 years ago

comment:2 batmoo3 years ago

Ah, didn't know Jane was reviewing stuff already. Will hold off, for now :)

comment:3 follow-up: scribu3 years ago

All ajaxified actions display a "Loading..." overlay accross the rows. Perhaps that should be made more proeminent, instead of the spinner.

comment:4 in reply to: ↑ 3 batmoo3 years ago

Replying to scribu:

All ajaxified actions display a "Loading..." overlay accross the rows. Perhaps that should be made more proeminent, instead of the spinner.

Turns out that the overlay was broken so I didn't know it existed (hence the reason for this ticket)! A central loading indicator/overlay definitely makes way more sense.

It could use some more prominence (and a spinner inside it wouldn't hurt ;)) but I'll leave that for the UI folks :)

batmoo3 years ago

Fixes loading overlay (was missing a closing quote)

comment:5 batmoo3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as dupe. See #14579 and #15580

comment:6 nacin3 years ago

  • Milestone Awaiting Review deleted

Commented there.

Note: See TracTickets for help on using tickets.