WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15504 closed defect (bug) (fixed)

Delete Permanently not working in Comments admin UI

Reported by: hew Owned by:
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: Comments Keywords: has-patch needs-testing
Focuses: Cc:

Description

Spam and/or trash a comment. Hover over and try to "Delete Permanently". Nothing happens.

Attachments (1)

15504.tentative.diff (460 bytes) - added by duck_ 3 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 mrmist3 years ago

Confirmed broken in trunk (using IE8)

comment:2 hew3 years ago

Thanks mrmist. I tested Safari/FF before submission and just now tested Chrome; it looks to be fully cross browser.

comment:3 lloydbudd3 years ago

  • Component changed from General to Comments
  • Milestone changed from Awaiting Review to 3.1

comment:4 duck_3 years ago

  • Keywords has-patch needs-testing added

Line 463 of edit-comments.js seems to be blocking the processing. Added in [10522] for deletion warnings, but looks like it was never removed when trashing was introduced.

Not too familiar with the code so tentative patch attached.

duck_3 years ago

comment:5 scribu3 years ago

I'm not sure, as that line was there in WP 3.0, yet the link was working.

comment:6 scribu3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [16516]) Use event delegation in edit-comments.js. Fixes #15504

comment:7 scribu3 years ago

(In [16517]) re-minify edit-comments.js. See #15504

comment:8 scribu3 years ago

Just like with #15488, all events need to be delegated.

Note: See TracTickets for help on using tickets.