WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#15509 closed defect (bug) (fixed)

Don't show the administration bar in plugin/theme install iframe

Reported by: ocean90 Owned by:
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

iframe_header() contains show_admin_bar( false ) and wp-admin/plugin-install.php

if ( isset( $_GET['tab'] ) && ( 'plugin-information' == $_GET['tab'] ) )
	define('IFRAME_REQUEST' , true);

So, normally there shouldn't be one.
Screenshot: http://grab.by/7uls | http://grab.by/7up7

Attachments (2)

15509.patch (442 bytes) - added by Utkarsh 4 years ago.
15509-network-admin.patch (2.1 KB) - added by SergeyBiryukov 4 years ago.

Download all attachments as: .zip

Change History (10)

@Utkarsh4 years ago

comment:1 @Utkarsh4 years ago

Patch attached.

comment:2 @voyagerfan57614 years ago

  • Cc WordPress@… added

comment:3 @Utkarsh4 years ago

  • Cc admin@… added
  • Keywords has-patch added; needs-patch removed

comment:4 @filosofo4 years ago

  • Keywords reporter-feedback added

Does this error still occur? I cannot reproduce it on current trunk.

comment:5 @Utkarsh4 years ago

  • Keywords reporter-feedback removed

Still present on a trunk MS install for me.

comment:6 @ocean904 years ago

Patch from Utkarsh is needed for the theme iframe. Plugin iframe works now.

comment:7 @ryan4 years ago

This doesn't work for plugin-install.php and theme-install.php in the network admin because they load admin.php before the IFRAME_REQUEST constant is defined.

comment:8 @PeteMall4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [16658]) Set IFRAME_REQUEST for theme/plugin information iframe. Props SergeyBiryukov, fixes #15509

Note: See TracTickets for help on using tickets.