WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 5 years ago

Last modified 5 years ago

#15520 closed enhancement (fixed)

Break date/time into a separate column in Comments views

Reported by: markel Owned by: wonderboymusic
Milestone: 4.4 Priority: normal
Severity: normal Version: 3.1
Component: Comments Keywords: has-patch has-screenshots
Focuses: ui, administration Cc:

Description

Now that column sorting is in, it makes sense to break the date and time a comment was made into a separate column in the Comments view so they can be sorted chronologically.

Currently, the time is part of the content column, which can be confusing as if someone sorts by that column it becomes an alphabetical sort.

Attachments (6)

commentcolumn.diff (4.5 KB) - added by jshreve 10 years ago.
Breaks out the submitted on text to its own sortable column
commentcolumn.png (41.8 KB) - added by jshreve 10 years ago.
Screenshot of date column for comments
comment_date_column.diff (4.5 KB) - added by jshreve 6 years ago.
refreshed patch
screenshot.png (128.4 KB) - added by jshreve 6 years ago.
refreshed screenshot
15520.diff (4.9 KB) - added by wonderboymusic 5 years ago.
comments-list-table.png (62.6 KB) - added by wonderboymusic 5 years ago.

Download all attachments as: .zip

Change History (26)

#1 @markel
10 years ago

  • Cc rmarkel@… added

#2 @scribu
10 years ago

  • Cc scribu added

@jshreve
10 years ago

Breaks out the submitted on text to its own sortable column

#3 @jshreve
10 years ago

  • Cc justin.shreve@… added

Made a quick patch that breaks out the "submitted on" text to its own sortable column. I debated creating a view link or keeping the date link clicakble but ended up keeping the date clickable. Also updated the inline help docs.

#4 @scribu
10 years ago

  • Keywords has-patch added

#5 @nacin
10 years ago

  • Keywords ux-feedback 2nd-opinion added
  • Milestone changed from Awaiting Review to 3.1

#6 follow-up: @JohnONolan
10 years ago

Screenshot please

@jshreve
10 years ago

Screenshot of date column for comments

#7 in reply to: ↑ 6 @jshreve
10 years ago

Replying to JohnONolan:

Screenshot please

Screenshot attached. As I mentioned we could also add a view link if we don't want the date linked still. Let me know and I can do another patch.

#8 follow-up: @JohnONolan
10 years ago

I like it in principle but think it might be too big of a UI change for this stage in the 3.1 cycle - translations and RTL need to be considered in particular.

This is an enhancement, not a bug, so I would suggest punting to 3.2

#9 @scribu
10 years ago

  • Keywords 3.2-early added
  • Milestone changed from 3.1 to Future Release

Agreed.

#10 @demetris
10 years ago

  • Cc dkikizas@… added

#11 in reply to: ↑ 8 @ramiy
9 years ago

  • Cc r_a_m_i@… added

#12 @chexee
9 years ago

  • Keywords needs-refresh added; 2nd-opinion 3.2-early removed

I think this is a good idea in principle as well. Would still like to see this in a Future Release.

The patch needs a bit of a refresh (fails at a few hunks for me. It adds the new column, but does not make it sortable).

#13 @jane
9 years ago

  • Keywords has-patch ux-feedback removed

Adding column fine by me.

#14 @ramiy
9 years ago

Can you break it into two lines:

current format "{date} at {time}"

new format "{date} <br /> {time}"

#15 @chriscct7
6 years ago

  • Focuses ui administration added
  • Keywords dev-feedback added

@jshreve
6 years ago

refreshed patch

@jshreve
6 years ago

refreshed screenshot

#16 @jshreve
6 years ago

Old ticket -- Don't even remember this ticket or working on this :) but I added a refreshed patch and ticket.

#17 @chriscct7
6 years ago

  • Keywords has-patch added; needs-refresh removed

Thanks @jshreve (so you know your efforts on this ticket are highly appreciated).

@wonderboymusic
5 years ago

#18 @wonderboymusic
5 years ago

  • Keywords has-screenshots added; dev-feedback removed
  • Milestone changed from Future Release to 4.4
  • Owner set to wonderboymusic
  • Status changed from new to assigned
  • Version set to 3.1

#19 @wonderboymusic
5 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 34504:

Comments: add date column to WP_Comments_List_Table to allow sorting and to break out the date/time from the comment content column.

Props jshreve.
Fixes #15520.

#20 @jorbin
5 years ago

In 35771:

Make comment screen row actions focusable

In [34504], tabbing through row actions on comments that lacked links was broken. This restores the desired behavior and ensures that the row actions can be seen by no-js users.

Second Permanent Committer sign off was by WonderBoyMusic

See #15520
Fixes #34791
Props afercia, azaozz

Note: See TracTickets for help on using tickets.