WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#15542 closed defect (bug) (invalid)

meta-box-sortables min-height causes display issues

Reported by: aaroncampbell Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: General Keywords:
Focuses: Cc:
PR Number:

Description

The problem is in wp-admin/css/wp-admin(.dev).css:

.postbox-container .meta-box-sortables {
	min-height: 300px;
}

It was added as part of [10641], which was in relation to dashboard widgets, but it seems to affect more than dashboard widgets. I'm not sure it's needed at all anymore, but if it is, maybe we can make it more specific?

.dashboard-widgets-wrap .postbox-container .meta-box-sortables {
	min-height: 300px;
}

Change History (3)

#1 @aaroncampbell
9 years ago

I came across this issue because I use meta boxes on the admin pages of many of my plugins. If an admin box doesn't have much content though, there is a funny space underneath it: http://s1187.photobucket.com/albums/z397/aarondcampbell/?action=view&current=spacing-issue.png

#2 @scribu
9 years ago

If you try to move the User Fields box from the screenshot closer under, doesn't the space go away?

#3 @scribu
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

You are not supposed to have two metabox sets under each other.

Without the min-height, you wouldn't be able to drag a metabox to an empty set.

Note: See TracTickets for help on using tickets.