WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15572 closed defect (bug) (fixed)

White screen bulk action but no selected comments

Reported by: duck_ Owned by: scribu
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: General Keywords: needs-patch
Focuses: Cc:

Description

  1. Visit wp-admin/edit-comments.php
  2. Perform a bulk action without checking any comments
  3. White screen

The problem is that wp_get_refere() is returning false (since _wp_http_referer == REQUEST_URI) and so the redirect on line 33 does nothing then we exit.

Pre-3.1 there was no exit call after the redirect so it just fell through and redirected at the end of the bulk action block where $redirect_to is set because add_query_arg (called by remove_query_arg) uses $_SERVER['REQUEST_URI'] when the old query is false.

Change History (3)

comment:1 scribu3 years ago

  • Owner set to scribu
  • Status changed from new to accepted

comment:2 scribu3 years ago

(In [16580]) Prevent WSOD when no comments selected for bulk action. See #15572

comment:3 scribu3 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.