WordPress.org

Make WordPress Core

Opened 3 years ago

Last modified 22 months ago

#15584 closed defect (bug)

Importers Specify Specific GPL version, should they? — at Version 1

Reported by: lloydbudd Owned by:
Milestone: WordPress.org Priority: low
Severity: minor Version: 3.1
Component: WordPress.org site Keywords:
Focuses: Cc:

Description (last modified by lloydbudd)

Importers Specify Specific GPL version, should they?

Before WordPress 3.0 the importers were in core, and did not include licensing information. It looks like when the GPL licensing info was added to WP & MT importer at least the versioning became explicit. This could affect future compatibility.

$ ack "GPL v2"

wp-content/plugins/movabletype-importer/movabletype-importer.php
10:License: GPL v2 - http://www.gnu.org/licenses/old-licenses/gpl-2.0.html

wp-content/plugins/wordpress-importer/wordpress-importer.php
9:License: GPL v2 - http://www.gnu.org/licenses/old-licenses/gpl-2.0.html

Should those be updated to

@license GPL - http://www.gnu.org/licenses/old-licenses/gpl-2.0.html

Change History (1)

comment:1 lloydbudd3 years ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.