WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15590 closed defect (bug) (invalid)

Media uploader giving non-admins wsod

Reported by: wpdavis Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.1
Component: Media Keywords:
Focuses: Cc:

Description

It seems the following line in wp-admin/includes/media.php is causing the WSOD for non-admins: <?php do_action('post-html-upload-ui', $flash); ?>

When that line is deleted the uploader comes back. With WP_DEBUG turned on I'm still getting no errors.

Not sure what changed — as far as I can find there were no plugins or code changes before this happened.

Change History (6)

comment:1 wpdavis3 years ago

P.S. that line is on 1517 in 3.0.1, 1539 in 3.1

comment:2 wpdavis3 years ago

  • Cc wpdavis added

comment:3 westi3 years ago

  • Keywords reporter-feedback added

I've just tested this in trunk as an Editor and cannot reproduce.

All that is hooked onto that action is this:

function media_upload_html_bypass($flash = true) {
	echo '<p class="upload-html-bypass hide-if-no-js">';
	_e('You are using the Browser uploader.');
	if ( $flash ) {
		// the user manually selected the browser uploader, so let them switch back to Flash
		echo ' ';
		printf( __('Try the <a href="%s">Flash uploader</a> instead.'), esc_url(add_query_arg('flash', 1)) );
	}
	echo "</p>\n";
}

I tried with both flash uploader enabled and disabled

comment:4 ocean903 years ago

  • Component changed from General to Media

comment:5 wpdavis3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Turned out to be a plugin problem, as far as I can tell. Sorry!

comment:6 ocean903 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted

Thx for the feedback.

Note: See TracTickets for help on using tickets.