WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15661 closed defect (bug) (duplicate)

Don't re-install HelloDolly when updating WordPress

Reported by: JohnONolan Owned by:
Milestone: Priority: low
Severity: minor Version: 3.0.2
Component: Upgrade/Install Keywords: ux-feedback
Focuses: Cc:

Description

HelloDolly is a quirky, fun part of WordPress. However if I'm running a site and I've chosen to delete the HelloDolly plugin from my install, then I do not want it forced on me every single time I run a WordPress core update. It's unexpected behaviour and a poor user experience.

Suggestion: Let's have the update script detect if HelloDolly exists and if it doesn't, skip installing the new HelloDolly files.

I appreciate that this is an annoying exception because HelloDolly is part of the complete WordPress package which we ship in updates - but I think it's worthy of some attention.

Unprompted traction for this is already evident after a single search: http://cl.ly/3UBx

Change History (5)

comment:1 follow-up: johnbillion3 years ago

Probably should apply to Akismet too

comment:2 demetris3 years ago

See #14484, which suggests the same for everything in wp-content.

comment:3 in reply to: ↑ 1 ; follow-up: markmcwilliams3 years ago

Replying to johnbillion:

Probably should apply to Akismet too

I believe Akismet isn't packaged now in the final .zips?!

comment:4 in reply to: ↑ 3 markmcwilliams3 years ago

Replying to markmcwilliams:

Replying to johnbillion:

Probably should apply to Akismet too

I believe Akismet isn't packaged now in the final .zips?!

Just ignore me, either I'm imagining something, or I've gone crazy? :$

comment:5 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.