WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15684 closed defect (bug) (invalid)

No feeds detected on this page (Alt+J)

Reported by: emiluzelac Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.2
Component: Feeds Keywords:
Focuses: Cc:

Description

Very recently I found that feed discovery does not get detected in IE8 nor IE7 Compatibility Mode. This is effecting TwentyTen Theme and sometimes random Theme in general.

Perfect example would be http://2010dev.wordpress.com/ where you can open the site in IE8 and look for RSS Feed icon in IE8 Command Bar. The icon will be orange while the page loads and as soon as the loading is complete, the icon will become gray "No feeds detected on this page (Alt+J)"

By looking at the source code application/rss+xml is there, however RSS is not detected.

Other example on non-Twenty Ten Theme is that application/rss+xml does not even load on example.com at all and it works just fine on any other pages for both RSS detection and application/rss+xml code loads in header.php.

You will correct me if I am wrong on this one, but I believe that IE8 should detect the RSS Feed normally.

Thanks,
Emil

Change History (6)

comment:1 nacin3 years ago

  • Keywords reporter-feedback added

Why is this the case? Other browsers don't have any trouble with it, and I don't see any inconsistencies in the code.

I don't think this is an issue with WP. If it's intermittent, chances are it's a browser issue.

comment:2 emiluzelac3 years ago

I am on Chrome and FF, however IE is on my check list at all times, that's how this came out. Few users of my clients blog complained about not getting the feed properly and sometimes at all.

If you believe that this is IE indeed, I apologize and you may close the ticket.

Thanks,
Emil

comment:3 follow-up: dd323 years ago

This is definitely a IE bug, but actually working out what the cause of the bug would be nice..

While the page is loading, IE is aware that there is a Feed for the page, but as soon as the dom document loaded action is fired, IE no longer detects the feed, it appears as if upon load, an extra request is made (possibly related to a stats plugin?) which ultimately causes IE to no longer detect the feed..

comment:4 in reply to: ↑ 3 emiluzelac3 years ago

I don't think that this was because of the plugin, because on my dev server there is none. As is now I am getting my VM installed to check IE7 and IE9 too, so that I can rule IE completely.

Thanks,
Emil

Replying to dd32:

This is definitely a IE bug, but actually working out what the cause of the bug would be nice..

While the page is loading, IE is aware that there is a Feed for the page, but as soon as the dom document loaded action is fired, IE no longer detects the feed, it appears as if upon load, an extra request is made (possibly related to a stats plugin?) which ultimately causes IE to no longer detect the feed..

comment:5 emiluzelac3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This was indeed IE8 bug, on VM Vista IE7 RSS feed is working properly on every single Twenty Ten and other Themes in question. Good thing is that we're aware of the issue.

comment:6 ocean903 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.