WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 7 years ago

#15705 closed defect (bug) (invalid)

I can't login to admin.

Reported by: ljmonet Owned by:
Milestone: Priority: highest omg bbq
Severity: blocker Version: 3.1
Component: Trash Keywords: has-patch nacin-unlikes close
Focuses: Cc:

Description

here is the error message I get when I go to the website and when I try to login to admin. I can't login to admin to take off the classified plugin that is causing the problem please help me get back in to admin because I have a high traffic blog and this is going on. it's on the #1 spot in google and it looks crazy wow this is not good.

Warning: Invalid argument supplied for foreach() in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 98

Warning: implode() [function.implode]: Invalid arguments passed in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 102

Warning: Invalid argument supplied for foreach() in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 98

Warning: implode() [function.implode]: Invalid arguments passed in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 102

Warning: Cannot modify header information - headers already sent by (output started at /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php:98) in /home/monavida/public_html/therealbigmoneymaker.com/wp-includes/pluggable.php on line 890

Attachments (1)

15705.diff (833 bytes) - added by Denis-de-Bernardy 9 years ago.

Download all attachments as: .zip

Change History (33)

#1 follow-up: @nacin
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

#2 @ljmonet
9 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#3 follow-up: @nacin
9 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

This is a plugin, clearly, not core. Please use the support forums.

#4 in reply to: ↑ 3 @ljmonet
9 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to nacin:

This is a plugin, clearly, not core. Please use the support forums.

I can't do anything I can't login to my admin to do anything. I thought this was where I have to go to get the help so you can get me back in wp-admin. Here's what I'm saying when I try to login to admin I get this message. This plugin I think caused it but where do I go to get back in to my admin area who can help me get back in my back office dashboard area do you see what I'm saying.

Warning: Invalid argument supplied for foreach() in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 98

Warning: implode() [function.implode]: Invalid arguments passed in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 102

Warning: Invalid argument supplied for foreach() in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 98

Warning: implode() [function.implode]: Invalid arguments passed in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 102

Warning: Cannot modify header information - headers already sent by (output started at /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php:98) in /home/monavida/public_html/therealbigmoneymaker.com/wp-includes/pluggable.php on line 890

#5 follow-up: @nacin
9 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Disable the plugin by renaming or removing the your-classified-ads folder. Then try the support forums.

Please don't re-open this ticket. This isn't the venue.

#6 in reply to: ↑ 5 @ljmonet
9 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to nacin:

Disable the plugin by renaming or removing the your-classified-ads folder. Then try the support forums.

Please don't re-open this ticket. This isn't the venue.

You don't understand HOW DO I DO THAT I CAN'T GET IN MY ADMIN AREA TO DO THAT. THERE IS NO LOGIN AND PASSWORD BOX TO LOGIN TO WORDPRESS TO GET TO MY BACK OFFICE ADMIN AREA. Do you see what I'm saying when I try to login I get this error message

Warning: Invalid argument supplied for foreach() in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 98

Warning: implode() [function.implode]: Invalid arguments passed in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 102

Warning: Invalid argument supplied for foreach() in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 98

Warning: implode() [function.implode]: Invalid arguments passed in /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php on line 102

Warning: Cannot modify header information - headers already sent by (output started at /home/monavida/public_html/therealbigmoneymaker.com/wp-content/plugins/your-classified-ads/includes/oqp.php:98) in /home/monavida/public_html/therealbigmoneymaker.com/wp-includes/pluggable.php on line 890

There is no login box to get in so that I can off load that plugin. This is not just a plugin issue, oh i need help with a plugin NO I can't login to admin back office of the wordpress dashboard area you see. Please help me with this thanks Jose

#7 @ljmonet
9 years ago

  • Summary changed from I can't login to admin. I loaded a classified plugin and everything went crazy to I can't login to admin.

Where do I go to get help so that I can see the login box so that I can LOGIN to my admin area. There is no Login box to login to my wp admin area who in wordpress can help me with this issue if you want to see what I'm saying go to www.therealbigmoneymaker.com/wp-admin and you will see that there is no login box thanks can anyone help me please thanks

#8 in reply to: ↑ 1 @ljmonet
9 years ago

Replying to nacin:

http://wordpress.org/support/

What is this for I don't understand?

#9 follow-up: @nacin
9 years ago

  • Keywords can't login to admin error message on blog removed
  • Resolution set to invalid
  • Severity changed from critical to normal
  • Status changed from reopened to closed

I don't need to be yelled at, thank you.

Log in through FTP. Then remove the plugin. Don't install it again. Then go use the support forums, not here.

What is this for I don't understand?

It's a link to the support forums, the proper place to ask for help. It is not, however, the proper place to yell in all caps at volunteers. There is no place for that.

#10 in reply to: ↑ 9 ; follow-up: @ljmonet
9 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to nacin:

I don't need to be yelled at, thank you.

Log in through FTP. Then remove the plugin. Don't install it again. Then go use the support forums, not here.

What is this for I don't understand?

It's a link to the support forums, the proper place to ask for help. It is not, however, the proper place to yell in all caps at volunteers. There is no place for that.

I'm not yelling at you man please understand that's what I'm doing. I don't have the time for that. I just need the help. I thought this is the place where you go for that. I went to the link that u gave me the first time and there is no help there man no one has the answers WP doesn't have tech support. Where do I go so someone can open the login box or fix this issue so that I can get back to my back office anyway man thanks for your time

#11 @nacin
9 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

You will get your login screen back when you log into FTP and delete the wp-content/plugins/your-classified-ads folder.

For someone who asks for help, you don't seem to be very receptive to receiving it.

#12 @technosailor
9 years ago

Can you help me with my Tumblr?

#13 in reply to: ↑ 10 @wpdavis
9 years ago

Replying to ljmonet:
there is no help there man no one has the answers WP doesn't have tech support. Where do I go so someone can open the login box or fix this issue so that I can get back to my back office anyway man thanks for your time

As amusing as this is, I'm starting to feel bad for Nacin.

The self-hosted version of WordPress does not have a tech support staff, that is true. The support forums are operated by volunteers, which is where to go if you have questions about your install. When you use WordPress on your own server it is assumed you have a relative amount of knowledge to be able to solve any problems that might arise.

If you can't handle a self-hosted install, I suggest looking at http://wordpress.com, http://page.ly or http://wpengine.com.

#14 @mrmist
9 years ago

Also your support thread was already answered.

http://wordpress.org/support/topic/i-dont-have-the-login-box-at-all-i-cant-login-to-my-admin-area?replies=3

Please use the forums, that's what they are there for.

#15 @Denis-de-Bernardy
9 years ago

  • Keywords has-patch added
  • Milestone set to Awaiting Review
  • Resolution invalid deleted
  • Status changed from closed to reopened

Re-opening this with a patch. WP shouldn't break this way if we can do something about it.

@ljmonet: as highlighted further up, as a rule you're getting what you paid for and there is no timely (if any) tech support for WP. (As MrMist pointed out, people did answer.)

That said, there are a few helpful users who will help you for a fee if what nacin suggested you to do is beyond your skills. (Then again, how hard can it be to browse to your therealbigmoneymaker.com site's directory, and then delete the your-classified-ads folder in wp-content/plugins?)

#16 @Denis-de-Bernardy
9 years ago

Patch is completely untested, and needs the following three tests before it gets checked in:

  • make sure the admin can login and stays logged in if a plugin issues a warning
  • make sure a plugin with a fatal error will still output something regardless of the output buffer
  • make sure a plugin with a fatal error will still get rejected by WP when user tries to activate it

#17 @wpdavis
9 years ago

@Denis-de-Bernardy It's not a cookies saved issue, it's a headers already sent issue on the login page (he's not seeing any login screen). I would consider it a non-issue because WP_DEBUG shouldn't be true on a production site.

#18 @nacin
9 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

wpdavis is correct, while this isn't WP_DEBUG, rather, display_errors shouldn't be true on a production site.

Denis: If you want to do that, open a new ticket. Closing this one.

We're done re-opening or commenting to this, everyone, okay?

#19 @nacin
9 years ago

  • Milestone Awaiting Review deleted

#20 @jorbin
9 years ago

Is this where I go for advice in how to install drupal?

#21 @ryanduff
9 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 3.0 to 3.1

I upgraded to 3.1 today and now I can't log into my back office again! Somebody please halp!

I think it may have something to do with not having Django installed but I wasn't told it was required in the release notes. Isn't this something that should be bundled with WordPress?

#22 @jorbin
9 years ago

  • Priority changed from normal to highest omg bbq
  • Severity changed from normal to blocker

#23 @JohnONolan
9 years ago

Drill baby drill.

#24 @ocean90
9 years ago

  • Component changed from Administration to Trash

#25 @nacin
9 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

#26 @jorbin
7 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Today I tried to access Admin Back Office and noticed that this bug still is present.

While using Netscape 4, I went to wordpress.org/back-office and it did not let me login.

Please help?

#27 @benbalter
7 years ago

I am able to reproduce this issue. No access to admin back office whatsoever, even with all extensions disabled.

Steps to reproduce:

  1. Navigate to /back-office

Expected:

  1. Able to log in to back office

Actual:

  1. Not able to log in to back office

#trolling

#28 @pbaylies
7 years ago

  • Cc pbaylies added

#29 @technosailor
7 years ago

I've traced it to jQuery not being enqueued properly. It's making the entire page 404.; +1 to getting this in WordPress 6.4

#30 @wycks
7 years ago

In order to use back office you have a client access licence("CAL"), possibly a conflict with GPL, please look into this before release.

#31 @markoheijnen
7 years ago

  • Keywords nacin-unlikes close added

#32 @rmccue
7 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Traced this down with the user, it was a problem with the server still running PHP/FI 2. We downgraded back to Personal Homepage Tools version 1, and it's all fixed now.

(On a more serious note, we really should stop opening this.)

Note: See TracTickets for help on using tickets.