WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#1571 closed defect (bug) (fixed)

Can't upload images using MarsEdit, mo:blog, etc

Reported by: miffo Owned by: markjaquith
Milestone: Priority: normal
Severity: major Version: 1.5.1.2
Component: Administration Keywords: image corrupt
Focuses: Cc:

Description

I tried to upload images to my WordPress installation but it doesn't seem to work, all images seems to be corrupted.

What happens is that I use MarsEdit to upload the images and if I directly try to access these images I get an error message similar to "PNG Error: [5C][30][0D]I: invalid chunk type" (same thing seems to happen for jpg). If I log into the server and check the image files they seem to have been corrupted in some way, I checked the content using an hexeditor and there are changes at the beginning of files as well as in other places.

Thinking this was a problem with MarsEdit I tried submitting pictures from my Palm using mo:blog but the result is the same. I then thought that there was a problem with my server (a debian installation) and asked if other had the same problems on the MarsEdit mailing list and it turned out that others had the same problem.

I'm using WP 1.5.1.3 (it wasn't possible to select this from the popup)

Change History (4)

comment:1 markjaquith9 years ago

  • Milestone set to 1.5.2
  • Owner changed from anonymous to markjaquith
  • Status changed from new to assigned

Please test using 1.5.2

I believe this issue was fixed in /branches/1.5/ shortly after 1.5.1.3 release

I'll close in a few days if I don't hear back.

comment:2 miffo9 years ago

I've just updated to 1.5.2 and now it seems to work again.

comment:3 miffo9 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:4 anonymous7 years ago

  • Milestone 1.5.2 deleted

Milestone 1.5.2 deleted

Note: See TracTickets for help on using tickets.