WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15711 closed defect (bug) (duplicate)

Fix Menu Management Metaboxes by making them Hierarchical & Ordered

Reported by: binarybit Owned by:
Milestone: Priority: normal
Severity: major Version: 3.1
Component: Menus Keywords: close
Focuses: Cc:

Description

Although the (now default) menu management functions have been built into the admin area we absolutely NEED a correctly sort the menu items within the metaboxes.

I am surprised this issue has not been addressed yet so what I am proposing is the following:

Whenever a metabox is displayed on the menu management page the items within this metabox should be sorted by their default Wordpress sort order so their order shows up exactly like they do within the admin post list pages.

For hierarchical pages the menu items should be presented in a hierarchical type view (just like a hierarchical categories/terms).

Currently the tab on top shows "most used" but I feel what I mentioned above is far more logical as the default and the user should be able to select from "most used" and possibly even "alphabetically".

Feedback? Votes on this?

Change History (3)

comment:1 nacin3 years ago

  • Keywords close added; menu management menus menu editor removed

This is a duplicate of two or three other tickets.

Part of the problem is scaling. We can't show potentially thousands of categories or pages by default. Hence most used is the default.

comment:2 follow-up: nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 in reply to: ↑ 2 hakre3 years ago

Replying to nacin:

Can you please give reference of which tickets this is a dupe before closing it? Otherwise it's not clear to which other ticket(s) you are referring to.

Probable duplicate of: #14660

Probably related to: #14180, #13329, #13217, #11817

Last edited 3 years ago by hakre (previous) (diff)
Note: See TracTickets for help on using tickets.