WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 2 years ago

#15719 closed enhancement (wontfix)

Connection Information dialog does not explain root problem

Reported by: novasource Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.2
Component: Filesystem API Keywords: needs-patch
Focuses: ui, administration Cc:

Description

On a brand new install of WordPress on a fresh Ubuntu 10.10 LAMP server, after trying to update a plugin, I got the Connection Information page that requested FTP information. ("To perform the requested action, WordPress needs to access to your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host.")

This message should have explained the root cause: my filesystem permissions did not allow WordPress to write. I think this error message is defective (a bug) because it doesn't explain the problem. Therefore, admins are forced to go on a wild goose chase to find the root cause and proposed an alternative (FTP) that I didn't even want to use.

Change History (5)

#1 @novasource
7 years ago

The last sentence could have been more clear. What I mean is the error does nothing to explain root cause, and WordPress just assumes I want to use FTP to edit files, which I didn't.

Also, I wish there was online documentation explaining this better. wordpress.org and Google searches were fruitless.

#2 @nacin
7 years ago

  • Keywords needs-codex added
  • Milestone changed from Awaiting Review to Future Release
  • Type changed from defect (bug) to enhancement

#3 @SergeyBiryukov
5 years ago

  • Component changed from UI to Text Changes

#4 @mikeschroder
4 years ago

  • Component changed from Text Changes to Filesystem API
  • Focuses ui administration added
  • Keywords needs-patch added

HI novasource!

Apologies that it took this long for the ticket to get a reply.
I like the idea of showing information about this particular problem, since I've seen this be a point of confusion before.

Part of the reason this likely hasn't been done yet is that there are more potential reasons you might be presented with the request for files over FTP, so this is probably not a straight text change. These include write permissions, ownership, general lack of finding directories, manual setting of connect type, and others. In wp-admin/includes/file.php, the form is showing for you because FTP has been selected as the "best" option for writing files to disk -- which in itself is not a bug, but rather a feature.

All this said, I'm certainly in support of making it easier for site admins to figure out why they can't use the 'direct' filesystem method, though.

#5 @chriscct7
2 years ago

  • Keywords needs-codex removed
  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Closing as wontfix. Complete lack of interest on the feature on the ticket over the last 3 years. Feel free to reopen when more interest re-emerges (particularly if there's a patch)

Note: See TracTickets for help on using tickets.