WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 11 months ago

Last modified 11 months ago

#15731 closed defect (bug) (wontfix)

Updating multiple plugins at once throws FTP error and leaves wp in maintenance mode

Reported by: koke Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0.2
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

http://img.skitch.com/20101208-pc3k6gej2piiewts246qrwwt18.jpg

The ftp error seems related to my iptables config and not a wp bug

LOG        all  --  anywhere             anywhere            limit: avg 5/min burst 5 LOG level debug prefix `iptables denied: ' 

But after the fail, I'm stuck with "Briefly unavailable for scheduled maintenance. Check back in a minute."

Change History (5)

comment:1 @ocean905 years ago

  • Keywords close added

Duplicate of #13988 ?

comment:2 @dd325 years ago

  • Keywords close removed

Doesn't look like a duplicate to me

It looks like a bit of a odd bug here, The FTP server is being disconnected mid-way on the upgrades..

On a single plugin upgrade this would be handled as a upgrade failure, but in bulk mode, it appears that it just continues onto the next plugin, which results in a FTP credentials page being flashed up.

Ultimately, to "fix" this, would require the server in question having it's configuration set better, however, in the event the connection is severed mid-way, it shouldn't attempt to do the next plugin before attempting to re-connect.

Maintainence mode will not be possible to deactivate until after the ftp connection is restored as well currently. We might be able to chmod it 777 and hopefully, WordPress could delete it after a failed ftp session directly without then need for FTP.. But it seems like a huge workaround for a simple problem: The FTP server is severing the connection early.

comment:3 @nacin5 years ago

  • Milestone changed from Awaiting Review to Future Release

comment:4 @chriscct711 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

Seems like an issue with the FTP server setup and not something WordPress should worry about trying to get around. Closing as wontfix unless someone has an objection

comment:5 @DrewAPicture11 months ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.