WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#15745 closed defect (bug) (invalid)

Static front page fails if permalinks set to anything other than default

Reported by: natebedortha Owned by: scribu
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Permalinks Keywords: reporter-feedback
Focuses: Cc:

Description

If Settings - Reading - Front page displays is set to a static page (e.g. About) and Permalinks are set to anything other than default, front page either returns nothing, or a list of recent posts.

Setting permalinks to to default fixes.

Tested on a brand new 3.1 install with Twentyten.

Change History (4)

comment:1 @scribu4 years ago

  • Owner set to scribu
  • Status changed from new to reviewing

comment:2 @scribu4 years ago

  • Keywords reporter-feedback added; permalinks front page display removed

I can't reproduce. Questions:

  • What is the custom permalink structure you used?
  • Do you also set "Posts page:" or leave it blank?

comment:3 @scribu4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from reviewing to closed

Turns out it was caused by the Shopp plugin.

comment:4 @nacin4 years ago

There have been quite a few posts regarding this in /support, which I'm kind of concerned about.

http://wordpress.org/support/topic/static-home-page-not-showing-31?replies=8

Note: See TracTickets for help on using tickets.