WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15766 closed defect (bug) (fixed)

jQuery UI 1.8.7

Reported by: demetris Owned by:
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: External Libraries Keywords: has-patch
Focuses: Cc:

Description

jQuery UI 1.8.7 was released earlier today:

http://blog.jqueryui.com/2010/12/jquery-ui-1-8-7/

I cannot tell myself whether it would be a safe update so late in the 3.1 dev cycle. I am attaching a patch anyway.

I have applied the patch to two sites of mine, to see how things look.

PS. I cannot find the JavaScript component. What happened to it?

Attachments (1)

t15766-jquery-ui-186-187.diff (97.9 KB) - added by demetris 3 years ago.
Updates jQuery UI from 1.8.6 to 1.8.7

Download all attachments as: .zip

Change History (7)

demetris3 years ago

Updates jQuery UI from 1.8.6 to 1.8.7

comment:1 ryan3 years ago

  • Milestone changed from Awaiting Review to 3.1

comment:2 ryan3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [16863]) jQuery UI 1.8.7. Props demetris. fixes #15766

comment:3 lloydbudd3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

This change was deployed to WordPress.com today, and resulted in
"Uncaught jQuery UI Tabs: Mismatching fragment identifier."
on http://newyork.cbslocal.com/

Last edited 3 years ago by lloydbudd (previous) (diff)

comment:4 scribu3 years ago

  • Component changed from General to External Libraries

comment:5 nacin3 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Closing as fixed.

Likely an issue with the existing JS that possibly affected UI versions < 1.8.7. The theme will need to be fixed. We can only address problems with core (wp-admin).

comment:6 ryan3 years ago

Background on the fragment identifier problem: As a result of the fix for <a href="http://bugs.jqueryui.com/ticket/6710">this bug</a>, jQuery UI is more strict about parentage. The issue is that UI.tabs expects the links to the tabs and the containers of tab content to have the same parent element. Well, really it’s that the element on which the tabs instance is initialized must be an ancestor of both the links and the tab contents containers. If you see this error you need to fix your theme/plugin.

Note: See TracTickets for help on using tickets.