WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 2 years ago

#15809 closed defect (bug) (duplicate)

Creating a category on the add/edit post page and pressing enter saves the post

Reported by: gilbitron Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.1
Component: UI Keywords: ux-feedback has-patch needs-testing dev-feedback 3.2-early
Focuses: Cc:

Description

When you create a category on the add/edit post screen and hit "enter" the expected behaviour is to create the category. Instead the post is saved and the category is not created.

Attachments (4)

post.dev.diff (641 bytes) - added by gilbitron 4 years ago.
garyc40-15809.patch (1.0 KB) - added by garyc40 4 years ago.
fixed "enter" keypress on both publish date and new category text fields, works in both new / edit for post / page
garyc40-15809-rev2.patch (1.0 KB) - added by garyc40 4 years ago.
removed "console.log"
garyc40-15809-rev3.patch (1.2 KB) - added by garyc40 4 years ago.
moved $.fn.submitTarget to post.dev.js, use generic instead of explicit jQuery object

Download all attachments as: .zip

Change History (10)

@gilbitron4 years ago

comment:1 @gilbitron4 years ago

This diff fixes the issue on the Edit Post screen but not on the Add Post screen.

comment:2 @JohnONolan4 years ago

  • Keywords ux-feedback has-patch needs-testing dev-feedback added; category save removed
  • Version set to 3.1

I've noticed this too - tripped me up several times.

comment:3 @JohnONolan4 years ago

  • Keywords early-3.2 added
  • Milestone changed from Awaiting Review to Future Release

comment:4 @johnbillion4 years ago

This could also be applied to the post date/time inputs as I've seen the same thing happen there a few times.

@garyc404 years ago

fixed "enter" keypress on both publish date and new category text fields, works in both new / edit for post / page

@garyc404 years ago

removed "console.log"

@garyc404 years ago

moved $.fn.submitTarget to post.dev.js, use generic instead of explicit jQuery object

comment:5 @aaroncampbell4 years ago

  • Keywords 3.2-early added; early-3.2 removed

comment:6 @SergeyBiryukov2 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14312.

Note: See TracTickets for help on using tickets.