WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#15834 closed defect (bug) (fixed)

Plugin action links are missing on plugins list, if the screen is to small.

Reported by: ocean90 Owned by:
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: UI Keywords: has-patch commit
Focuses: Cc:

Description

So, break it please.

Attachments (3)

15834.patch (528 bytes) - added by ocean90 5 years ago.
15834.2.patch (685 bytes) - added by ocean90 5 years ago.
'.plugins .action-links' is not needed anymore too.
test-plugin-action-links.php (203 bytes) - added by scribu 5 years ago.

Download all attachments as: .zip

Change History (18)

@ocean905 years ago

comment:1 @nacin5 years ago

Screenshot?

comment:2 @ocean905 years ago

http://grab.by/7UP3 - Delete and Edit links are missing.

comment:3 @nacin5 years ago

That sounds like an overflow:hidden that needs to be removed, rather than removing nowrap.

Not sure what else nowrap might cause -- side-effects are possible.

comment:4 @scribu5 years ago

  • Cc scribu added

comment:5 @scribu5 years ago

Ideally, the action links would expand the column width as necessary. Don't think that's possible in a <table>, though.

comment:6 @nacin5 years ago

Can someone do some more digging here today?

comment:7 @ocean905 years ago

It's not only the action links, also the plugin title will be hidden, if there is not enough space.

Version 0, edited 5 years ago by ocean90 (next)

comment:8 @ocean905 years ago

I can't see a problem with my patch here. It's the same behavior like on network/themes, network/users, network/sites.

@ocean905 years ago

'.plugins .action-links' is not needed anymore too.

comment:9 @ryan5 years ago

#8810 for some history

comment:10 @scribu5 years ago

  • Keywords needs-patch added; has-patch removed

This is a regression from 3.0, but the current patch doesn't fix it.

comment:11 @scribu5 years ago

Sorry, was caused by me having SCRIPT_DEBUG off (but STYLE_DEBUG on). Different bug.

Patch works, but it goes against #8810.

comment:12 @scribu5 years ago

  • Keywords has-patch commit added; needs-patch removed

After further review, I think the current patch is the way to go. It works and it will make the plugins screen consistent with all the rest.

comment:13 @ryan5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [17116]) Remove unnecessary nowraps. Props scribu. fixes #15834

comment:14 @scribu5 years ago

Yeah, props should go to ocean90, since it was his patch.

comment:15 @garyc404 years ago

Removing nowrap makes plugins table look bad. See #16536.

Note: See TracTickets for help on using tickets.