WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#15849 closed defect (bug) (fixed)

Search Bug in Network Admin

Reported by: pmaiorana Owned by: scribu
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: Network Admin Keywords: has-patch
Focuses: multisite Cc:

Description

Steps to reproduce:

1) From /wp-admin/network/ Search Users for a non-existant user; it's important that it's a non-existant user because this bug only happens when no results are returned.

2) You should now be on a User Search results page and see the string "No users found."

3) From that page, search using the box in the top-right for another user that DOES exist.

4) The page will still return "No users found", even though it should return at least one matching user.

In our testing the bug has been fairly consistent, but not 100% reproducible every time. Try multiple attempts and multiple browsers if you don't see it on first pass.

Attachments (2)

quick.15849.diff (786 bytes) - added by scribu 11 years ago.
Disable ajaxification if there are no items
placeholder.15849.diff (4.5 KB) - added by scribu 11 years ago.
Always display the table, with placeholder row

Download all attachments as: .zip

Change History (11)

#1 @westi
11 years ago

  • Cc westi added
  • Component changed from General to Network Admin

#2 @westi
11 years ago

This is probably a generic List Table and query string search issue.

We should check them all.

#3 @westi
11 years ago

  • Milestone changed from Awaiting Review to 3.1
  • Version set to 3.1

#4 @scribu
11 years ago

  • Owner set to scribu
  • Status changed from new to accepted

#5 @scribu
11 years ago

The root cause of the bug is the inconsistency between screens with no items, depending on wether you got there via an ajaxified action or via URL (directly).

@scribu
11 years ago

Disable ajaxification if there are no items

#6 @scribu
11 years ago

  • Keywords has-patch added

quick.15849.diff is a quick fix for 3.1.

A better solution would be to always display the table, but with a placeholder row when there are no items.

Working on a patch for that.

@scribu
11 years ago

Always display the table, with placeholder row

#7 @scribu
11 years ago

placeholder.15849.diff is the better solution, which turns out isn't too hard to implement.

#8 @scribu
11 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [17002]) Always display the table, with a placeholder row when there are no items. Fixes #15849

#9 @scribu
11 years ago

(In [17003]) Remove placeholder row when adding first term. See #15849

Note: See TracTickets for help on using tickets.