WordPress.org

Make WordPress Core

Opened 3 years ago

Last modified 7 weeks ago

#15855 new defect (bug)

Dropdown isn't shown when doing a user 'removal' — at Version 4

Reported by: scribu Owned by:
Milestone: Future Release Priority: normal
Severity: normal Version:
Component: Users Keywords: has-patch needs-testing ux-feedback
Focuses: multisite Cc:

Description (last modified by scribu)

Steps to reproduce:

  1. Have a MultiSite install
  2. Go to wp-admin/users.php and delete a user
  3. A confirmation screen appears, with only a "Confirm" button.

Expected behaviour:

The user dropdown is shown, asking to assing the user's posts to a different user.

Currently, you end up with authorless posts.

Change History (4)

comment:1 nacin3 years ago

  • Milestone changed from Awaiting Review to 3.1

comment:2 nacin3 years ago

We need to figure out what is a regression here and fix that.

My thoughts:

  • A user can only be removed from a blog in the site admin. Actual user deletion must occur from the network admin.
  • On removing a user from a blog in the site admin, we need to be able to reassign their posts.
  • Post reassignments cannot reasonably occur in the network admin. Perhaps a warning that this user may have data in blogs they are attached to (if get_blogs_of_user() > 0) and that's it.

comment:3 scribu3 years ago

Post reassignments cannot reasonably occur in the network admin.

Funily enough, that's already what happens now: you get a dropdown for each site.

comment:4 scribu3 years ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.