WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15857 closed defect (bug) (fixed)

"No items found" when I have categories

Reported by: garyc40 Owned by: garyc40
Milestone: 3.1 Priority: normal
Severity: normal Version:
Component: Administration Keywords: needs-patch
Focuses: Cc:

Description

Go to Posts -> Categories. Even though you have categories, they are not listed. Instead "No items found" is shown.

The pagination controls show the correct total pages. Parent dropdown is populated correctly.

Attachments (1)

garyc40-15857.patch (1.2 KB) - added by garyc40 3 years ago.
fixed "No items for ..."

Download all attachments as: .zip

Change History (10)

comment:1 nacin3 years ago

  • Milestone changed from Awaiting Review to 3.1
  • Priority changed from normal to highest omg bbq
  • Severity changed from normal to blocker

comment:2 garyc403 years ago

  • Owner set to garyc40
  • Status changed from new to assigned

comment:3 follow-up: ocean903 years ago

NOTICE: wp-admin/includes/class-wp-terms-list-table.php:339 - Undefined property: stdClass::$taxonomy

garyc403 years ago

fixed "No items for ..."

comment:4 in reply to: ↑ 3 garyc403 years ago

Replying to ocean90:

NOTICE: wp-admin/includes/class-wp-terms-list-table.php:339 - Undefined property: stdClass::$taxonomy

Can't reproduce. How did you get this? I tried inline editing but there was no errors.

comment:5 garyc403 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

comment:6 scribu3 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [17025]) Display categories again. Props garyc40. Fixes #15857

comment:7 scribu3 years ago

  • Keywords needs-patch added; has-patch needs-testing removed
  • Resolution fixed deleted
  • Severity changed from blocker to major
  • Status changed from closed to reopened

The search box is never shown.

We should make WP_Terms_List_Table populate $items in prepare_terms().

comment:8 scribu3 years ago

(In [17026]) Always show term search box. See #15857

comment:9 scribu3 years ago

  • Priority changed from highest omg bbq to normal
  • Resolution set to fixed
  • Severity changed from major to normal
  • Status changed from reopened to closed

This will have to do for now, since the code for displaying hierarchical taxonomies is pretty messy.

Note: See TracTickets for help on using tickets.