WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#15875 closed defect (bug) (duplicate)

Admin bar deforms with :before pseudoselector and content proprierty

Reported by: pablox Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.1
Component: Administration Keywords: has-patch needs-testing
Focuses: Cc:
PR Number:

Description

In a website that I'm developing I had this on my style.css:

ul li:before{
    content: "+ "
}

Basically I wanted to add a "+" as a list bullet (I know that's a weird thing to do, and of course I can add an image; and I think I will). But the thing is that results in deforming the admin bar as you can see from the screenshot I attach.

Adding:

#wpadminbar ul li:before {
	content: none;
}

On wp-includes/css/admin-bar.css solves the issue. Not big deal anyway, but has a simple/easy solution :)

Attachments (3)

wp-beta-admin-bar.png (26.6 KB) - added by pablox 9 years ago.
Admin bar with :before content
15875.diff (397 bytes) - added by duck_ 9 years ago.
15875.2.diff (397 bytes) - added by duck_ 9 years ago.

Download all attachments as: .zip

Change History (8)

@pablox
9 years ago

Admin bar with :before content

#1 @pablox
9 years ago

  • Component changed from Themes to Administration

#2 @duck_
9 years ago

  • Keywords needs-patch added; admin bar :before content css removed
  • Milestone changed from Awaiting Review to 3.1

Moving to 3.1, though can probably close a dupe of a super ticket for admin bar CSS resets.

Related: #15851

@duck_
9 years ago

#3 @duck_
9 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

Attached a patch with a more generic content reset so a:before, for example, doesn't affect the admin bar. Also went with content: "" as well as content: none because Chromium didn't seem to like none. Testing from some CSS experts please.

#4 @JohnONolan
9 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

duck_ let's move to #15851 like you said

@duck_
9 years ago

#5 @ocean90
9 years ago

  • Milestone 3.1 deleted
Note: See TracTickets for help on using tickets.