WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15877 closed defect (bug) (fixed)

Link Categories has wrong parent in admin menu

Reported by: duck_ Owned by:
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: Administration Keywords: has-patch commit
Focuses: Cc:

Description

When viewing or editing link categories (wp-admin/edit-tags.php?taxonomy=link_category) the Posts menu is expanded and displayed as active.

I imagine setting $parent somewhere would fix this.

This is a regression.

Attachments (1)

15877.diff (597 bytes) - added by duck_ 3 years ago.

Download all attachments as: .zip

Change History (7)

duck_3 years ago

comment:1 duck_3 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

15877.diff not entirely sure if this is the right way about it, but performs the reset when the taxonomy is 'link_category'.

comment:2 duck_3 years ago

Related: #12285

comment:3 JohnONolan3 years ago

I am able to replicate - screenshot http://cl.ly/3gpl

comment:4 scribu3 years ago

Can't reproduce. The correct link is highlighted when on wp-admin/edit-tags.php?taxonomy=link_category.

comment:5 scribu3 years ago

  • Keywords commit added; needs-testing removed

Ah, now I see what you mean. Patch works fine.

comment:6 ryan3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [17041]) Fix menu highlight for link category edit. Props duck_. fixes #15877

Note: See TracTickets for help on using tickets.