WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 2 years ago

#15897 closed enhancement (wontfix)

Comment replies on Pending view of edit-comments.php

Reported by: jane Owned by: garyc40
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Comments Keywords: has-patch needs-testing 3.2-early
Focuses: Cc:

Description

To reproduce: Go to the Pending view of the comments screen at /edit-comments.php?comment_status=moderated and make a comment reply. The reply is auto-approved, but remains shown on the Pending screen below the original comment. The post count # in parenthesis above does not change. Approve the original comment and it disappears from the screen, the comment count # in parenthesis above updates to reflect the action, but the approved reply is still showing on the Pending screen (though not included in the comment count).

It's a twitchy little interaction: on one hand, having the comment reply disappear on submit would be disorienting, but at the same time, having approved comments appear on the Pending screen is disorienting. When the comment is approved, both comment and reply should disappear together.

However, this will happen automatically if we change the interaction model (proposed in separate ticket) so that submitting a reply also approves the original comment.

Attachments (3)

garyc40-15897.patch (9.1 KB) - added by garyc40 4 years ago.
there's a patch for that
Screen shot 2010-12-26 at 7.21.50 PM.png (7.5 KB) - added by garyc40 4 years ago.
replied & approved notice
15897.2.diff (14.4 KB) - added by garyc40 3 years ago.
patch refreshed

Download all attachments as: .zip

Change History (7)

comment:1 garyc404 years ago

Related to #15898 (Change comment Reply to Reply and Approve if comment in moderation)

comment:2 garyc404 years ago

  • Owner set to garyc40
  • Status changed from new to assigned

garyc404 years ago

there's a patch for that

garyc404 years ago

replied & approved notice

comment:3 garyc404 years ago

  • Keywords has-patch needs-testing 3.2-early added

The patch for this ticket is based on the patch I submitted at #15898, because obviously this ticket depends on #15898.

It's only a rough patch, but the behavior you wanted is there:

  • Reply to an unapproved comment in Pending view makes both the comment and reply disappear.
  • There's a small notice when they disappear (just like the Undo box when you trash a comment) to hopefully make things less confusing for the user (see screenshot, you might want to modify the wording).

garyc403 years ago

patch refreshed

comment:4 jane2 years ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from assigned to closed

Closing wontfix because #15898 added approve & reply, which solves issue.

Note: See TracTickets for help on using tickets.