WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 9 years ago

#1594 closed defect (bug) (invalid)

"Update Permalink Structure" needs tweaking

Reported by: christined Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.1.2
Component: Administration Keywords: permalinks
Focuses: Cc:

Description

The tweaking it needs, depends on what it should be doing...

At the moment, if there is no value specified for the permalink structure; when you click the "Update Permalink Structure" button, the .htaccess isn't updated but the "Permalinks were updated" message displays and the category base value is saved to the database.

This is bad for two reasons: 1. The message displayed is inaccurate 2. It means that the category base and any rewrite rules added by plugins can't be used unless there's also a permalink structure specified (which doesn't seem like an absolutely required pre-requisite; but Viper007Bond had mentioned in the forums that it was by design)

Either: A message to the effect of "Permalinks weren't updated because there's no permalink structure specified" should display when you try and save; or having other rewrite rules without a permalink structure should be allowable.

Change History (2)

comment:1 @echozone10 years ago

Had similar happen updating from 1.5.1.1 to 1.5.2 (so not sure this is also for 1.5.1.2).
New .htaccess with permissions 666. Options/Permalinks with Structure filled in + Category base left blank.
Results in message that permalinks updated, but blank .htaccess file.

Tried multiple times. If I did not set permissions writable, then I could get the text needed to paste manually, and the permalinks work fine, although I haven't tested adding a new page or category.

comment:2 @rob1n9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

WP 2.0 and up uses a new rewriting system which takes care of this stuff.

Note: See TracTickets for help on using tickets.