WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 8 years ago

#15977 closed feature request (duplicate)

Send the Locale in Plugin/Theme Update Check Requests

Reported by: dimadin Owned by: nacin
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Upgrade/Install Keywords: 3.2-early
Focuses: Cc:

Description

Currently, we send locale (and other information about installation) only in wp_version_check and not in wp_update_plugins and wp_update_themes.

Since we still don't know how system for plugins/themes localization will work, I propose that we send this from 3.1.

Why? As said above, there is no definitive agreement on how will localization system work, but it is possible that system wont require changes in core, ie. be same or similar to one I suggested over at Polyglots.

In that case localization system will be made independently what means that it'll can start working before 3.2 version. If we don't send locale for plugins/themes, we will need to wait for 3.2 even though that wont be significant change.

In theory, plugin/theme developers could also benefit if alongside locales, we would send all information we send in wp_version_check and later show them as are plugin versions shown now.

I know that is very late for this change but issue with plugin localization tool has been ignored for a very long time as I described in my post mentioned above in more detail.

Change History (7)

#1 @nacin
11 years ago

  • Milestone changed from Awaiting Review to 3.1

#2 @nacin
11 years ago

  • Milestone changed from 3.1 to Future Release

Sorry, wrong button.

#3 @westi
11 years ago

  • Keywords 3.2-early added

I think we should try and come up with a awesome localization system as one of the 3.2 features.

#4 @nacin
11 years ago

  • Owner set to nacin
  • Status changed from new to accepted

I'll be approaching this from the GlotPress side as well, so accepting it for the core side.

#5 @wonderboymusic
9 years ago

Is this still a thing?

#7 @nacin
8 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from accepted to closed

Duplicate of #18200.

Note: See TracTickets for help on using tickets.