WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#15996 closed defect (bug) (worksforme)

Changing permalinks to custom makes all categories return error 404

Reported by: wpolitika Owned by: Wpolitika
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Permalinks Keywords:
Focuses: Cc:

Description

Hello,

I've been struggling with this problem for two days and I can't figure out what is wrong. The problem seems to be around for 1-2 months but only now have I noticed it.
I am using WordPress 3.1 RC1, the website we are talking about is http://www.notebrother.com.

The issue goes like this:
I am using custom permalinks that have the following structure: /%year%/%monthnum%/%day%/%postname%/

All posts work fine with this permalink structure so I suppose this is not a .htaccess problem.
However if I try to access a category archive, let's say http://www.site.com/category/news/ I get the following error:

Error 404 - Not Found

We're very sorry, but that page doesn't exist or has been moved.
Please make sure you have the right URL.

This problem disappears if I revert to the default permalinks. Using http://www.site.com/?category_name=news works all the time, regardless of what I am doing to the permalinks.

Also if I want to use %category% in the permalink structure, this will make all posts inaccessible, but without an error, the server will simply not be able to process the request and act as if it's down.

I tend to believe this might be due to a bug in version 3.1.

Change History (22)

comment:1 garyc403 years ago

Have you tried reproducing the problem on a fresh install of WP 3.1 RC1? It could have been caused by a custom plugin or theme.

comment:2 wpolitika3 years ago

Just tested on a fresh install of wordpress with only a few random posts. Seems there is no problem there.

I doubt it's due to a plugin, because I've systematically deactivated most of them in order to pin point the problem.

I try to dig more into the issue and see if I can pin point the problem.

Thanx for the support.

comment:3 follow-up: wpolitika3 years ago

Update:
we've tested the website with all plugins disabled and with theme disabled, in other words, using the default theme.

The problem persists even in this case. Any other ideas?

comment:4 SergeyBiryukov3 years ago

Might be related to .htaccess. What are the rules there?

comment:5 wpolitika3 years ago

    # BEGIN WordPress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

# END WordPress

Permission set to 666

Version 1, edited 3 years ago by wpolitika (previous) (next) (diff)

comment:6 follow-up: SergeyBiryukov3 years ago

Looks correct. Also, what is the category base value under the Permalinks settings?

comment:7 in reply to: ↑ 6 wpolitika3 years ago

Replying to SergeyBiryukov:

Looks correct. Also, what is the category base value under the Permalinks settings?

I've let that blank. There is nothing there.

comment:8 wpolitika3 years ago

My only solution right now is to delete the current version of wordpress and do a clean reinstall. But this seems to me like a lot of pain. Is it even possible ?

comment:9 wpolitika3 years ago

I was unable to pin point the problem. The only solution was to reinstall wordpress and revert to version 3.0.3.

Everything seems to be working fine now after re-installation. You can close this ticket... although the real cause of the problem has not been identified.

Thank you for all your support.

comment:10 nacin3 years ago

  • Milestone changed from Awaiting Review to 3.1

comment:11 nacin3 years ago

  • Keywords reporter-feedback added; custom permalinks category bug removed

comment:12 in reply to: ↑ 3 westi3 years ago

Replying to wpolitika:

Update:
we've tested the website with all plugins disabled and with theme disabled, in other words, using the default theme.

The problem persists even in this case. Any other ideas?

Are you using any drop-ins that were still active?

DB Caching, Object Caching etc.

comment:13 tar.gz3 years ago

Just reminding that the /%category%/ element in custom permalinks was causing weird issues in earlier 3.1 builds, see Ticket #15487.

However, on my current WP 3.1-RC1-17163 test install, /%year%/%monthnum%/%day%/%postname%/ is working perfectly fine.

comment:14 markjaquith3 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

No one else has been able to reproduce this. Reopen if you can, or if you have more information!

comment:15 voidtrance3 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 3.1 to 3.2.1

I am having the same issue and so far all my tracking and debugging points to WP.

  1. .htaccess and mod_rewrite are working fine - verified by the fact that individual posts are working and also by examining Apache's mod_rewrite log file.
  2. confirmed it is not a plugin issue - turned off all plugins, issue still exists.
  3. confirmed it is not a theme issue - issue still exists with default TwentyEleven theme.

Any permalink structure which has the variables %category% or %tag% does not seem to work.
I am using /%year%/%monthnum%/%postname%/ as my permalink structure. With that, individual posts work file. Accessing any category or tag archive /%category%/<name> or /%tag%/<name> results in 404 Error.

However, if I change the permalink structure to /%category%/%year%/%monthnum%/%postname%/, all of sudden, even individual posts start returning 404 errors.

comment:16 follow-up: ocean903 years ago

  • Milestone changed from 3.1 to Awaiting Review
  • Severity changed from major to normal
  • Version changed from 3.2.1 to 3.1

Please don't change the reported in version to a newer version. Then we lose the history of when the bug was identified.

Also some more information would be nice.

comment:17 pavelevap3 years ago

  • Cc pavelevap@… added

comment:18 in reply to: ↑ 16 voidtrance3 years ago

Replying to ocean90:

Please don't change the reported in version to a newer version. Then we lose the history of when the bug was identified.

Also some more information would be nice.

Sorry about that!!
What additional information would you like?

comment:19 follow-up: ocean903 years ago

Sorry about that!! What additional information would you like?

Does it works in previous versions, does it happen on a clean install too, if possible try it on another server, so that we can check if it's a server issue. Plugins are disabled and default theme is used?

comment:20 in reply to: ↑ 19 voidtrance3 years ago

Replying to ocean90:

Sorry about that!! What additional information would you like?

Does it works in previous versions, does it happen on a clean install too, if possible try it on another server, so that we can check if it's a server issue. Plugins are disabled and default theme is used?

As mentioned in my original message, yes the plugins were all disabled and the default TwentyEleven them was used.

I don't have another server to try so I can't give you that data point but I will attempt to do a clean install.

comment:21 voidtrance3 years ago

After much debugging with new installs, database migrations, and import/exports, it turned out that the problem was the Multi-Page Toolkit plugin.

The reason why it appeared that turning off all the plugins did not make a difference is that once the Multi-Page Toolkit plugin was turned off, I had to re-"Save Changes" on the permalinks settings page in order for WP to start working.

My problem seems to be resolved.

comment:22 ocean903 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Thanks for your investigations. Maybe you should ask the plugin author what is going on there.

Re-closing as worksforme.

Note: See TracTickets for help on using tickets.