WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#15998 closed defect (bug) (fixed)

"Show more comments" does not work on edit posts screen if you have comments per page less than 10

Reported by: greuben Owned by:
Milestone: 3.1 Priority: normal
Severity: major Version: 3.1
Component: Comments Keywords: has-patch
Focuses: Cc:

Description

Set comments per page to 1 and edit a post with more than one comment. "Show more comments" is not displayed at all. If you have 10 or more comments to that post "Show more comments" is displayed but if you click on it will display "No more comments found."

Attachments (3)

15998.diff (1.9 KB) - added by greuben 4 years ago.
15998.only.10.patch (476 bytes) - added by ocean90 4 years ago.
15998-2.diff (1.2 KB) - added by greuben 4 years ago.

Download all attachments as: .zip

Change History (9)

greuben4 years ago

comment:1 greuben4 years ago

  • Keywords has-patch added

comment:2 ocean904 years ago

  • Component changed from Administration to Comments
  • Milestone changed from Awaiting Review to 3.1
  • Version set to 3.1

It's a regression.

But I think, that we shouldn't use edit_comments_per_page here, because 100 comments on the post page would be to much, but rather use the old fix value 10. I attached a patch with my idea.

ocean904 years ago

comment:3 ryan4 years ago

Let's hard code to 10 somewhere in WP_Post_Comments_List_Table. Maybe have WP_Comments_List_Table use a get_per_page() method that WP_Post_Comments_List_Table can override.

comment:4 nacin4 years ago

  • Keywords needs-patch added; has-patch removed

greuben4 years ago

comment:5 greuben4 years ago

  • Keywords has-patch added; needs-patch removed

comment:6 ryan4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [17168]) Hard limit to 10 comments on edit post screen. Props greuben. fixes #15998

Note: See TracTickets for help on using tickets.