WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#16017 closed defect (bug) (fixed)

RTL fixes for comments list

Reported by: SergeyBiryukov Owned by: garyc40
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.1
Component: RTL Keywords: has-patch
Focuses: Cc:

Description

As originally reported by Rasheed Bydousi on WP Polyglots:

Snapshot: http://img703.imageshack.us/img703/3889/99392434.gif
Location: wp-admin/edit-comments.php

  1. “Check for Spam” button position – There is an extra 8px margin on top of the button.
  2. “In reply to” should have a right float.
  3. “Author” should have a right float.
  4. “Un-spammed by” should have a left float.

Attachments (4)

garyc40-16017.patch (3.2 KB) - added by garyc40 3 years ago.
there's a patch for that
garyc40-16017-rev2.patch (3.3 KB) - added by garyc40 3 years ago.
fixed ajax spinner when saving draft
garyc40-16017-rev3.patch (3.0 KB) - added by garyc40 3 years ago.
removed unnecessary styles introduced in previous patches
16017.patch (909 bytes) - added by ocean90 3 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 garyc403 years ago

  • Owner set to garyc40
  • Status changed from new to assigned

garyc403 years ago

there's a patch for that

comment:2 garyc403 years ago

The patch I attached corrected problems #1, #2 and #3.

Problem #4 can be fixed in Akismet stylesheet, so it's not included in my patch.

There's also a change I made in WP_Comments_List_Table, where the positions of "In reply to" and "Submitted on" are reversed in the case of RTL. Don't know if it's really necessary, but I ran with it anyways.

garyc403 years ago

fixed ajax spinner when saving draft

garyc403 years ago

removed unnecessary styles introduced in previous patches

comment:3 garyc403 years ago

  • Keywords has-patch needs-testing added

comment:4 follow-up: ocean903 years ago

Is it a regression?

@garyc40
Tortoise doesn't like your patch. :-(

comment:5 in reply to: ↑ 4 garyc403 years ago

Replying to ocean90:

Is it a regression?

@garyc40
Tortoise doesn't like your patch. :-(

I don't think it's a regression, except for sortable table header floating (which is already fixed in [17166]).

Sorry, seems like diff generated by git is not parsed properly in Turtoise :( Works fine in command line though.

comment:6 follow-up: ocean903 years ago

How it looks without the patch (trunk, language: AR): http://grab.by/87Sg

#1: Where is the Check for Spam button?

#2: Looks good. Fixed by [17166].

#3: Looks good too. Fixed by [17166].

#4: Un-spammed by seems to be from Askimet.

Can't see a problem here anymore, close?

Last edited 3 years ago by ocean90 (previous) (diff)

comment:7 SergeyBiryukov3 years ago

Replying to ocean90:

Is it a regression?

Points 2 and 3 are a regression from 3.0. Point 1 is not. Not sure about point 4.

comment:8 follow-up: garyc403 years ago

I should probably have created a separate ticket for this, but could you check Posts -> Add New ? The button "Preview" has a little bit of padding to the left.

My rev2.patch fixes this. Needs to add this to wp-admin-rtl.dev.css:

#minor-publishing .ajax-loading { 
        float:right; 
        padding:3px 4px 0 0; 
} 

comment:9 in reply to: ↑ 6 SergeyBiryukov3 years ago

Replying to ocean90:

#1: Where is the Check for Spam button?

It's from Akismet, but it uses native .button-secondary class. garyc40's patch fixes the margin.

Last edited 3 years ago by SergeyBiryukov (previous) (diff)

comment:10 in reply to: ↑ 8 SergeyBiryukov3 years ago

Replying to garyc40:

I should probably have created a separate ticket for this, but could you check Posts -> Add New ? The button "Preview" has a little bit of padding to the left.

Confirmed. This is a regression too.

ocean903 years ago

comment:11 ocean903 years ago

  • Keywords i18n needs-testing removed
  • Milestone changed from Awaiting Review to 3.1

16017.patch will fix the regressions #1 and garyc40's one.

#2 and #3 are fixed through [17166].

#4 is for Askimet, SergeyBiryukov will create a ticket for it.

comment:13 markjaquith3 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [17179]) Fix some RTL CSS issues. props garyc40. props ocean90. fixes #16017

Note: See TracTickets for help on using tickets.