WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#16019 closed enhancement (maybelater)

Search queries should return results based on author name

Reported by: computerwiz908 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: General Keywords: dev-feedback
Focuses: Cc:

Description

When searching a WordPress blog using the name of an author, the author's posts do not come up; the search function only looks for the name in the full text of the posts. There should be a way for the search function to also look at the author of each article when performing queries.

Change History (8)

comment:1 computerwiz9083 years ago

  • Keywords needs-patch added; search author removed

comment:2 ocean903 years ago

  • Keywords reporter-feedback added; needs-patch removed

Can you test it with 3.1 RC1 please, it works for me here.

comment:3 hakre3 years ago

While testing, please check if searching for tags works as well. I had problems to locate posts by their tags (backend ajax search in the post listing). That's probably related (for 3.1 not 3.0).

Version 1, edited 3 years ago by hakre (previous) (next) (diff)

comment:4 computerwiz9083 years ago

  • Keywords dev-feedback added; reporter-feedback removed

Neither tags nor author display names work when searching for articles in my test site with RC1. I made sure that the author name/tag was not in the full text of the article.

comment:5 dd323 years ago

  • Type changed from defect (bug) to enhancement

Searching currently only searches the contents of posts, not the metadata about the posts. Setting as enhancement, This may be a duplicate of an older search-related ticket.

Note, There are plugins around which greatly enhance WordPress's searching functionality.

comment:6 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

comment:7 computerwiz9083 years ago

  • Cc computerwiz908@… added
  • Resolution maybelater deleted
  • Status changed from closed to reopened
  • Version changed from 3.0.3 to 3.1

I am reopening because there aren't any third-party plugins that provide searching articles with the author name in the query, and it should be a core feature of WordPress. Also, I cannot find any previous bugs that are duplicates of this issue.

comment:8 nacin3 years ago

  • Resolution set to maybelater
  • Status changed from reopened to closed

Check out the Search Everything and Search plugins. We don't think this should be a core feature of WordPress for now (it's not scalable, for one) -- hence maybelater. On the other hand, if we end up reconsidering search in the future, we don't need tickets to remind us what we would want to implement.

Note: See TracTickets for help on using tickets.