WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 2 years ago

Last modified 22 months ago

#16022 closed enhancement (maybelater)

Search does not look for tags

Reported by: hakre Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Taxonomy Keywords: has-patch
Focuses: Cc:

Description

While 3.1 Beta Testing I ran over this:

Ajax search is to search the (paginated) table. The table has tags in it's display. Search is not looking for those.


How to reproduce?

  1. Edit a Post.
  2. Add a new Tag that doesn't exist so far.
  3. Update the Post.
  4. Go to Posts.
  5. Search for the just created Tag.
  6. You get an empty search result.

See #14579 and #15580

Attachments (1)

16022.diff (2.1 KB) - added by greuben 5 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 @nacin5 years ago

Regression? I wasn't aware we ever searched tags.

comment:2 @duck_5 years ago

Same in 3.0.3 for me. (I made sure the post title/content had no similarity to the tag slug)

comment:3 @ocean905 years ago

  • Version changed from 3.1 to 3.0

Regression?

No.

@greuben5 years ago

comment:4 @greuben5 years ago

  • Keywords has-patch added

searching for tags doesn't work on front end also

comment:5 @scribu5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Not a regression and we already have a 'posts_search' filter.

comment:6 @hakre4 years ago

Related: #16163; #16162

Last edited 4 years ago by hakre (previous) (diff)

comment:7 @hakre4 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Type changed from defect (bug) to enhancement

comment:8 @scribu4 years ago

Do you mind explaining why you reopened the ticket?

comment:9 follow-up: @scribu4 years ago

  • Summary changed from Backend Post Ajax search does not look for page tags to Search does not look for tags

As already stated, no search, ajax or not, in the back-end or on the front-end, includes terms, be them tags, categories or a custom taxonomy.

comment:10 in reply to: ↑ 9 @hakre4 years ago

Replying to scribu:

Do you mind explaining why you reopened the ticket?

I changed it from Bug to Enhancement (as you wrote it's not a bug), that's why.


Replying to scribu:

As already stated, no search, ajax or not, in the back-end or on the front-end, includes terms, be them tags, categories or a custom taxonomy.

As already stated, the table displays that information. The search above is in context of it. I'm talking about the back-end only, the ajax tables in specific. But probably a UI/UX expert should review this.

Last edited 4 years ago by hakre (previous) (diff)

comment:11 @scribu4 years ago

  • Keywords ux-feedback added
  • Milestone set to Awaiting Review

comment:12 @voyagerfan57614 years ago

  • Cc WordPress@… added

comment:13 @westi4 years ago

  • Component changed from General to Taxonomy
  • Keywords 3.2-early added
  • Milestone changed from Awaiting Review to Future Release

Patch works for me.

comment:14 @scribu4 years ago

  • Keywords 3.2-early removed

Doesn't fit into 3.2. We're trying to make things faster. :)

comment:15 @wonderboymusic2 years ago

  • Keywords ux-feedback removed
  • Milestone Future Release deleted
  • Resolution set to maybelater
  • Status changed from reopened to closed

UI/UX expert should review this

I just got certified to be one online: I vote no - this ticket is old, search is already bad, this is better as a plugin for now. Ozz's patch for relevance hasn't even made it in yet.

Note: See TracTickets for help on using tickets.