WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#16029 closed defect (bug) (duplicate)

Rework search box for attaching non-attached media

Reported by: ocean90 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Media Keywords:
Focuses: Cc:

Description

I mean this box on upload.php:
http://grab.by/87ee

You get this search box if you want to attach an item to an existing post/page/{post type}.


It's now 2 years old and needs an update.
As a suggestion you can take the internal linking box (#11420).

A small mockup: http://grab.by/87g1


Features:

  • AJAX search
  • show recent items, like internal linking
  • show all post types in one box, like internal linking (http://grab.by/87gy)
  • use thickbox, maybe iframe


Related: #13229, r8901

Attachments (1)

16029.patch (16.3 KB) - added by ocean90 3 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 @ocean904 years ago

  • Keywords ui-feedback added

comment:2 @kawauso4 years ago

Related: #17859

comment:3 @ocean904 years ago

  • Keywords gci removed

@ocean903 years ago

comment:5 follow-up: @lessbloat3 years ago

I took a look at 16029.patch. When I search for "Google", I get "no matches are found", even though I have a post titled "Google".

comment:6 @ocean903 years ago

  • Keywords needs-patch ui-feedback removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20164.

comment:7 in reply to: ↑ 5 @ocean903 years ago

Replying to lessbloat:

I took a look at 16029.patch. When I search for "Google", I get "no matches are found", even though I have a post titled "Google".

The patch isn't final since it doesn't have a new dialog. The goal was to use the same as for internal linking, but the dialog has some TinyMCE dependencies.

So #20164 has a nice patch and we can close this ticket as a duplicate of it.

Note: See TracTickets for help on using tickets.