WordPress.org

Make WordPress Core

Changes between Initial Version and Version 1 of Ticket #16031, comment 98


Ignore:
Timestamp:
10/13/2016 06:02:59 PM (4 years ago)
Author:
Veraxus
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #16031, comment 98

    initial v1  
    1919* Refactor the admin screens to standardize variable naming conventions
    2020  * Note: Refactoring previously vetoed as out of scope for this ticket.
    21 * Separate the network-targetted hooks into `handle_network_bulk_actions-*` solely because those hooks get the site id as an extra argument (unnecessary, IMO).
     21* If the fourth (site id) argument is the main concern, we can either:
     22  * Separate the network-targetted hooks into `handle_network_bulk_actions-*` solely because those hooks get the site id as an extra argument (unnecessary, IMO).
     23  * Provide a default value (e.g. `false`) for the fourth argument on non-network implementations of the hook.
    2224
    2325If your concern is with the PhpDocs having disparate variable names, the first option is the only solid option IMO... since proxying data into another variable just for the sake of the docs seems like incurring more tech debt on screens that already have quite a bit of that (see: disparate naming conventions and patterns).